杭电1224

Free DIY Tour

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It’s a good chance to relax themselves. To most of them, it’s the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company’s statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

Input

The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

Output

For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit.

Output a blank line between two cases.

Sample Input

2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4

Sample Output

CASE 1#
points : 90
circuit : 1->3->1

CASE 2#
points : 90
circuit : 1->2->1

思路:

用Floyd算法求最长路径。
注意以下两点:(还不太明白)

  • 输入时,city [j] = - city [j]
  • 输出时,- fun [1] [n+1]

AC代码:

#include<iostream>
#include<cstring>
using namespace std;

const int INF=0xfffffff;
const int maxn=105;

int n,m;
int city[maxn];//以数字形式记录城市的好玩程度 
int map[maxn][maxn];//记录两个城市是否连通
int fun[maxn][maxn];//以连通边形式记录好玩程度 
int path[maxn][maxn];//记录路径 

void init()
{
    for(int i=0;i<maxn;i++)
    {
        for(int j=0;j<maxn;j++)
        {
            fun[i][j]=INF;//初始化 
            if(map[i][j]==1) fun[i][j]=0;//i,j连通则初始化为0 
        }
    }
}

void floyd()
{
    //path的初始化 
    for(int i=1;i<=n+1;i++)
    {
        for(int j=1;j<=n+1;j++)
        {
            path[i][j]=j;
        }
    }
    //floyd
    for(int k=1;k<=n+1;k++)
    {
        for(int i=1;i<=n+1;i++)
        {
            for(int j=1;j<=n+1;j++)
            {
                if(fun[i][j]>(fun[i][k]+fun[k][j]+city[k]))
                {//经过k就要加上k的好玩程度 
                    fun[i][j]=fun[i][k]+fun[k][j]+city[k];
                    path[i][j]=path[i][k];
                    //记录i连通哪一个点能达到最大好玩程度 
                }
            }
        }
    }
}

int main()
{
    int t,a,b,icase=0;
    cin>>t;//t个测试用例 
    while(t--)
    {
        memset(map,0,sizeof(map));
        memset(path,0,sizeof(path));
        cin>>n;//n个城市  
        for(int j=1;j<=n;j++)
        {
            cin>>city[j];//输入城市的好玩程度 
            city[j]=-city[j];
        }
        //对n加1后,最后一个城市也是起始城市,好玩程度为0
        city[n+1]=0;
        cin>>m;
        for(int j=1;j<=m;j++)
        {
            cin>>a>>b;//输入城市连通情况 
            map[a][b]=1; //记录a与b连通 
        }

        init();//初始化 
        floyd();//找最长路径 

        cout<<"CASE "<<++icase<<"#"<<endl;
        cout<<"points : "<<-fun[1][n+1]<<endl;
        cout<<"circuit : ";
        //输出路径信息 
        for(int j=1;1;j=path[j][n+1])
        {
            if(j==n+1)
            {
                cout<<"1";
                break;
            }
            else cout<<j<<"->";
        }
        cout<<endl; 
        if(t!=0) cout<<endl;//两个输出间要有空行 
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/albert_bolt/article/details/81106771
今日推荐