牛客多校第四场 D Another Distinct Values

题目描述

Chiaki has an n x n matrix. She would like to fill each entry by -1, 0 or 1 such that r1,r2,...,rn,c1,c2, ..., cn are distinct values, where ri be the sum of the i-th row and ci be the sum of the i-th column.

输入描述:

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 200), indicating the number of test cases. For each test case:
The first line contains an integer n (1 ≤ n ≤ 200) -- the dimension of the matrix.

输出描述:

For each test case, if no such matrix exists, output ``impossible'' in a single line. Otherwise, output ``possible'' in the first line. And each of the next n lines contains n integers, denoting the solution matrix. If there are multiple solutions, output any of them.

样例输入

2
1
2

样例输出输出

impossible
possible
1 0
1 -1

这道题找一找规律,便能解决。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int a[205][205];
int main() {
	int t, n;
	scanf("%d", &t);
	while(t--) {
		memset(a, 0, sizeof(a));
		scanf("%d", &n);
		if(n % 2 == 0) {//只有n为偶数的时候,才有可能创建出
			for(int i = 1; i <= n; i++) {
				for(int j = 1; j <= n; j++) {
					if(i > n/2) {
						if(j < i) {
							a[i][j] = -1;
						} else {
							a[i][j] = 0;
						}
					} else {
						if(j > i - 1) {
							a[i][j] = 1;
						} else {
							a[i][j] = 0;
						}
					}
				}
			}			
			printf("possible\n");
			for(int i = 1; i <= n; i++) {
				for(int j = 1; j <= n; j++) {
					if(j == n) {
						printf("%d\n", a[i][j]);
					} else {
						printf("%d ", a[i][j]);
					}
				}
			}
		} else {
			printf("impossible\n");
		}

	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/adusts/article/details/81267662