SDUT OJ 数据结构实验之栈与队列五:下一较大值(一)

数据结构实验之栈与队列五:下一较大值(一)

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

对于包含n(1<=n<=1000)个整数的序列,对于序列中的每一元素,在序列中查找其位置之后第一个大于它的值,如果找到,输出所找到的值,否则,输出-1。

Input

 输入有多组,第一行输入t(1<=t<=10),表示输入的组数;

以后是 t 组输入:每组先输入n,表示本组序列的元素个数,之后依次输入本组的n个元素。

Output

 输出有多组,每组之间输出一个空行(最后一组之后没有);

每组输出按照本序列元素的顺序,依次逐行输出当前元素及其查找结果,两者之间以-->间隔。

Sample Input

2
4 12 20 15 18
5 20 15 25 30 6 

Sample Output

12-->20
20-->-1
15-->18
18-->-1

20-->25
15-->25
25-->30
30-->-1
6-->-1

Hint

 本题的数据量小、限时要求低,可以不用栈来完成。

Source

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
int main()
{
    int t;
    cin>>t;
 for(int k=1;k<=t;k++)
    {
        int n;
        cin>>n;
        int i,j;
        int a[1033];
        for(i=0; i<n; i++)
            cin>>a[i];

        for(i=0; i<n; i++)
        {int flas=1;
            for(j=i; j<n; j++)
            {
                if(a[i]<a[j])
                {
                    flas=0;
                    printf("%d-->%d\n",a[i],a[j]);
                    break;
                }
            }
            if(flas)printf("%d-->-1\n",a[i]);

        }

      if(k!=t)cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81383522
今日推荐