SDUT OJ 数据结构实验之栈与队列六:下一较大值(二)

数据结构实验之栈与队列六:下一较大值(二)

Time Limit: 150 ms Memory Limit: 8000 KiB

Submit Statistic Discuss

Problem Description

对于包含n(1<=n<=100000)个整数的序列,对于序列中的每一元素,在序列中查找其位置之后第一个大于它的值,如果找到,输出所找到的值,否则,输出-1。

Input

 输入有多组,第一行输入t(1<=t<=10),表示输入的组数;

以后是 t 组输入:每组先输入n,表示本组序列的元素个数,之后依次输入本组的n个元素。

Output

 输出有多组,每组之间输出一个空行(最后一组之后没有);

每组输出按照本序列元素的顺序,依次逐行输出当前元素及其查找结果,两者之间以-->间隔。

Sample Input

扫描二维码关注公众号,回复: 2552054 查看本文章
2
4 12 20 15 18
5 20 15 25 30 6 

Sample Output

12-->20
20-->-1
15-->18
18-->-1

20-->25
15-->25
25-->30
30-->-1
6-->-1

Hint

 本题数据量大、限时要求高,须借助栈来完成。

Source

#include<stdio.h>
#include<iostream>
using namespace std;
int main()
{
    int t;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            int a[100001];
            int b[100001];
            int st[100001];
            int n;
           cin>>n;
            int i;
            for(i=0; i<n; i++)
            {
               cin>>a[i];
            }
            b[n-1]=-1;
            int top=0;

            for(i=n-2; i>=0; i--)
            {
                int flas=0;
                if(a[i+1]>a[i])
                {
                    b[i]=a[i+1];
                    st[++top]=a[i+1];
                }
                else
                {
                    while(top!=0)
                    {
                        if(st[top]>a[i])
                        {
                            flas=1;
                            b[i]=st[top];
                            break;
                        }
                        top--;
                    }
                    if(flas==0)b[i]=-1;
                }
            }
            for( i=0; i<n; i++)
              printf("%d-->%d\n",a[i],b[i]);//这里我用cout输出是不对,不理解


            if(t)
                cout<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81393346
今日推荐