P - Cheapest Palindrome POJ - 3280

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

题意:给一个字符串,求将它变成回文串需要花费的最小值。

解题思路:

对于一个单独的字符来说,删掉和在对称位置添加相同的新字母的效果是一样的。所以不用纠结是删除还是添加。只要使用花费最少的操作就行。(剩下的就是变成回文字符串需要最少的花费)

dp[i][j]代表的是第i个字符到第j个字符要成为回文串需要的最小花费。它只由dp[i+1][j]+对第i个字符操作的最小花费和dp[i][j-1]+对第j个字符操作的最小花费之间的最小值决定 ,当第i个字符等于第j个字符时,还要加上dp[i+1][j-1],即判断三个数的最小值。

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
char s[2005],c[3];
int dp[2005][2005],cost[30];
int main()
{
    int n,m,t,i,j;
    while(~scanf("%d%d",&n,&m))
    {
        scanf("%s",s);
        for(i=0; i<n; i++)
        {
            scanf("%s",c);
            scanf("%d%d",&cost[c[0]-'a'],&t);
            if(t<cost[c[0]-'a'])
                cost[c[0]-'a']=t;
        }
        memset(dp,0,sizeof(dp));
        for(i=m-1; i>=0; i--)
        {
            for(j=i+1; j<m; j++)
            {
                dp[i][j]=min(dp[i+1][j]+cost[s[i]-'a'],dp[i][j-1]+cost[s[j]-'a']);
                if(s[i]==s[j])
                    dp[i][j]=min(dp[i][j],dp[i+1][j-1]);
            }
        }
        printf("%d\n",dp[0][m-1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lihuanz/article/details/81435017