A Dangerous Maze LightOJ - 1027 (期望dp)

You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the ith door, it can either take you back to the same position where you begun in ximinutes, or can take you out of the maze after xi minutes. If you come back to the same position, you can't remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the ith integer (xi) is positive, you can assume that the ith door will take you out of maze after xi minutes. If it's negative, then the ith door will take you back to the beginning position after abs(xi) minutes. You can safely assume that 1 ≤ abs(xi) ≤ 10000.

Output

For each case, print the case number and the expected time to get out of the maze. If it's impossible to get out of the maze, print 'inf'. Print the result in p/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input

3

 

1

1

 

2

-10 -3

 

3

3 -6 -9

Sample Output

Case 1: 1/1

Case 2: inf

Case 3: 18/1

 

思路:这是求期望的一般套路题。

先直接设要求期望为E,那么对于能出去的情况,选到他们任意一个的概率都是1/n,所以设sum1为所有正数之和,

设sum2为所有负数之和的绝对值,且负数个数为a

那么E=sum1/n+(sum2+a*E)/n

因为对于每一个回到原来位置的门,还需要E的期望才能离开。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
#include <set>
#include <string>
#include <math.h>
#include <stack>
using namespace std;
typedef long long ll;
const int maxn = 1e5+10;
#define inf 0x3f3f3f3f
int n;
int a[maxn];
int main(int argc, char const *argv[])
{
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
        freopen("out.txt","w",stdout);
    #endif
    int T;
    int Case=0;
    cin>>T;
    while(T--)
    {
        scanf("%d",&n);
        int a0=0,a1=0;
        int s1=0,s2=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>0) 
            {
                a0++;
                s1+=a[i];
            }
            if(a[i]<0)
            {
                a1++;
                s2+=abs(a[i]);
            }
        }
        if(a0==0)
        {
            printf("Case %d: inf\n",++Case);
        }
        else
        {
            int tmp=s1+s2;
            int g=__gcd(a0,tmp);
            printf("Case %d: %d/%d\n",++Case,tmp/g,a0/g);
        }

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40774175/article/details/81570509