Mad Scientist(暴力AC/简单模拟)

A mad scientist performed a series of experiments, each having n phases. During each phase, a measurement was taken, resulting in a positive integer of magnitude at most k. The scientist knew that an individual experiment was designed in a way such that its measurements were monotonically increasing, that is, each measurement would be at least as big as all that precede it. For example, here is a sequence of measurements for one such experiment with n = 13 and k = 6:

1, 1, 2, 2, 2, 2, 2, 4, 5, 5, 5, 5, 6

It was also the case that n was to be larger than k, and so there were typically many repeated values in the measurement sequence. Being mad, the scientist chose a somewhat unusual way to record the data. Rather than record each of n measurements, the scientist recorded a sequence P of k values defined as follows. For 1 ≤ j ≤ k, P(j) denoted the number of phases having a measurement of j or less. For example, the original measurements from the above experiment were recorded as the P-sequence:

2, 7, 7, 8, 12, 13

as there were two measurements less than or equal to 1, seven measurements less than or equal to 2, seven measurement less than or equal to 3, and so on. Unfortunately, the scientist eventually went insane, leaving behind a notebook of these P-sequences for a series of experiments. Your job is to write a program that recovers the original measurements for the experiments.

Input

The input contains a series of P-sequences, one per line. Each line starts with the integer k, which is the length of the P-sequence. Following that are the k values of the P-sequence. The end of the input will be designated with a line containing the number ‘0’. All of the original experiments were designed with 1 ≤ k < n ≤ 26.

Output

For each P-sequence, you are to output one line containing the original experiment measurements separated by spaces.

Sample Input

6 2 7 7 8 12 13

1 4

3 4 4 5

3 0 4 5

5 2 2 4 7 7

0

Sample Output

1 1 2 2 2 2 2 4 5 5 5 5 6

1 1 1 1

1 1 1 1 3

2 2 2 2 3

1 1 3 3 4 4 4

暴力AC代码:(控制好格式)

(个人觉得代码确实很啰嗦,所以改良了一下...)

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=105;
int str1[maxn];
int main()
{
    int n,i;
    while(cin>>n && n)
    {
        memset(str1,0,sizeof(str1));
        for(i=0;i<n;i++)
        {
            cin>>str1[i];
        }
        int flag=2;
        int index=str1[0];
        while(index--)
        {
            cout<<"1";
            if(index)
            {
                cout<<" ";
            }
        }
        int INDEX=1;
        if(str1[0]==0)
        {
            INDEX=0;
        }
        for(i=1;i<n;i++)
        {
            int index1=str1[i]-str1[i-1];
            while(index1--)
            {
                if(INDEX)
                {
                    cout<<" ";
                }
                INDEX++;
                cout<<flag;
            }
            flag++;
        }
        cout<<endl;
    }
    return 0;
}

改良后的模拟解法:

#include<iostream>
using namespace std;
const int maxn=105;
int main()
{
    int n,i;
    int str2[maxn];
    int str1[maxn]={0};
    while(cin>>n && n)
    {
        for(int i=1;i<=n;i++)
        {
            cin>>str1[i];
        }
        int ans=0;
        for(i=1;i<=n;i++)
        {
            for(int j=1;j<=str1[i]-str1[i-1];j++)
            {
                str2[ans++]=i;
            }
        }
        cout<<str2[0];
        for(i=1;i<ans;i++)
        {
            cout<<" "<<str2[i];
        }
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq1013459920/article/details/81627644
MAD