PAT甲级--1023 Have Fun with Numbers(20 分)【大整数乘法】

1023 Have Fun with Numbers(20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

解题思路:就直接模拟乘法就好了,判断是不是原来的那几个数字的排列,就用下标统计就ok了。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
int ac[11],bc[11];
int main(void)
{
	string a;
	cin>>a;
	string b=a;
    int len=a.size(),flag=1, c=0;
    memset(ac,0,sizeof ac);
    memset(bc,0,sizeof bc);
    for(int i=len-1;i>=0;i--)//模拟乘法
	{
		ac[a[i]-'0']++;
		b[i]=((a[i]-'0')*2+c)%10+'0';
		c=((a[i]-'0')*2+c)/10;//处理进位
	 } 
    if(c)//最高位乘法以后可能进位不为0
    {
    	char d=c+'0';
    	b=d+b;
    	flag=0;
	}
    for(int i=0;i<b.size();i++) bc[b[i]-'0']++;
    for(int i=0;i<10;i++)
    {
    	if(ac[i]!=bc[i])
    	{
    		flag=0;
    		break;
		}
	}
	printf("%s\n",flag?"Yes":"No");
	cout<<b<<endl;
	return 0;
 }

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82083708