Agri-Net

版权声明:本文为博主原创文章,转载时注明出处,附加链接即可。 https://blog.csdn.net/cswhit/article/details/53132970
Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 54110   Accepted: 22469

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
这个题跟highway类似,不过这个是把权值相加
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

int main()
{
	int mp[110][110],dis[110];
    int n,i,j;
    while(~scanf("%d",&n))
    {
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
				scanf("%d",&mp[i][j]);
		int sum=0;
		for(j=1;j<=n;j++)
			dis[j]=mp[1][j];
		for(i=1;i<n;i++)
		{
			int min=100000,p;
			for(j=1;j<=n;j++)
			{
				if(dis[j]&&dis[j]<min)
				{
					min=dis[j];
					p=j;
				}
			}
			sum+=min;
			dis[p]=0;
			for(j=1;j<=n;j++)
				if(dis[j]>mp[p][j])
					dis[j]=mp[p][j];
		}
		cout<<sum<<endl;
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/cswhit/article/details/53132970