Halloween Costumes (区间DP)

VJ链接

题目:

Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it's Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of 'Chinese Postman'.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn't like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N (1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ith integer ci (1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output

For each case, print the case number and the minimum number of required costumes.

Sample Input

2

4

1 2 1 2

7

1 2 1 1 3 2 1

Sample Output

Case 1: 3

Case 2: 4

题意:一个人要参加n次舞会, 每次舞会都要穿特定的衣服编号为s[i],这个人可以在衣服外边套衣服, 但衣服一旦脱下来就不能再穿了, 必须买新的衣服, 求需要的最少衣服。

题解:挺难想到是区间DP, DP[i][j]记录第i 次到第 j次需要的最少衣服数, 当s[i] == s[j]时, dp[i][j] 就是 dp[i][j - 1]。

不同的是这个题目的区间分割是有条件的, 当s[i] == s[k](k < j)时可以进行分割:

dp[i][j] = min(dp[i][j], dp[i][k] + dp[k + 1][j]。

AC代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int dp[105][105] = {0}, s[105];
int main()
{
    int i, j, k, n, ans, len, t, T;
    scanf("%d", &T);
    for(t = 1;t <= T;t++){
        scanf("%d", &n);
        for(i = 1;i <= n;i++)
            scanf("%d", &s[i]);
        for(i = 1;i <= n;i++)
            dp[i][i] = 1;//初始化为1,是最差的情况
        for(len = 1;len <= n;len++){
            for(i = 1;i <= n;i++){
                j = i + len;//区间终点
                dp[i][j] = 0x3f3f3f3f;//取最大值,便于更新
                if(s[i] == s[j])
                    dp[i][j] = dp[i][j - 1];//相同的衣服可以继续用
                for(k = i;k < j;k++)
                    if(s[i] == s[k])
                        dp[i][j] = min(dp[i][j], dp[i][k] + dp[k + 1][j]);//状态转移
            }
        }
        printf("Case %d: %d\n", t, dp[1][n]);
        memset(dp, 0, sizeof(dp));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/LxcXingC/article/details/81354313
今日推荐