poj-1452-按天数卖东西

Supermarket
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 13224   Accepted: 5920

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

Source


题意:

超市里有n个产品要卖,每个产品都有一个截至时间dx(从开始卖时算起),只有在这个截至时间之前才能卖出并且获得率润dy。
有多个产品,所有可以有不同的卖出顺序,每卖一个产品要占用1个单位的时间,问最多能卖出多少利润。

方法:含结构体的优先队列

 
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;

struct node
{
    int day, intr;
    bool operator < (const node& x) const//对优先队列的操作要熟
    {
        return intr<x.intr;
    }
};

int cmp(node x, node y)
{
    return x.day>y.day;
}
node s[10005];
priority_queue<node>p;
int main()
{
    int n, sum;
    while(cin >> n)
    {
        sum = 0;
        for(int i=0; i<n; i++)
        cin >> s[i].intr >> s[i].day;
        sort(s,s+n,cmp);
        int t = s[0].day, pos = 0;
        for(int i=t; i>0; i--)//从最大天数向下枚举
        {
            while(pos<n && i==s[pos].day)//如果该天数存在商品截止期,则存入这些商品
            {
                p.push(s[pos++]);
            }
            if(!p.empty())//无论上面是否存入商品,只要非空(有商品可在这天卖出),则找寻价值最大商品卖出
            {
                sum += p.top().intr;
                p.pop();
            }
        }
        while(!p.empty())
            p.pop();
        cout << sum << endl;
    }
    return 0;
}

 
 

 
 

猜你喜欢

转载自blog.csdn.net/Accept1234/article/details/76037800