1041 Be Unique (20 分)(map)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print Noneinstead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None
#include<iostream>
#include<cmath>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<set>
#include<map>
#include<vector>
#include<string>
using namespace std;
typedef long long ll;
int main(){
    int n;
    cin>>n;
    map<int,int> m;
    vector<int> v;
    for(int i = 0 ; i < n ; i++)
    {
        int k;
        cin>>k;
        v.push_back(k);
        m[k]++;
    }
    bool flag = false;
    int res;
    for(int i = 0; i < v.size(); i++)
    {
        if(m[v[i]]==1){
            flag = true;
            res = v[i];
            break;
        }
    }
    if(flag){
        cout<<res<<endl;
    }
    else{
        cout<<"None";
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41988545/article/details/83625472