A1041 Be Unique (20 分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10^​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10^​5​​) and then followed by Nbets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

题意:

 给出N (≤10​^5​​) 个数字from [1,10^​4​​].,问按照读入的顺序,哪个数字是第一个在所有数字中只出现一次的数字。如果所有数字出现的次数均超过一次,则输出“None”.

注意:

  1. 数字最大取到10000,因此散列数组至少开到10001
  2. 采用散列数组在读入数字时,记录该数字的出现次数。但注意本题要求输出第一个,采用 a[100001] 按顺序记录输入的数字
#include <cstdio>
int a[100001], hasnTable[10001] = {0};
int main(){
  int n;
  scanf("%d", &n);
  for(int i = 0; i < n; i++){
    scanf("%d", &a[i]);
    hasnTable[a[i]]++;
  }
  int ans = -1;
  for(int i = 0; i < n; i++){
    if(hasnTable[a[i]] == 1){
      ans = a[i];
      break;
    }
  }
  if(ans == -1)
    printf("None");
  else
    printf("%d\n", ans);
  return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_35093872/article/details/86625275