POJ 2492 - A Bug's Life (种类并查集)

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

题意:

      给你n只虫子,m对虫子之间的关系,问他们之间是否存在同性恋。

思路:

     种类并查集的关键在于与结点与根结点的距离, 如果距离是奇数那么性别就和跟结点相反,如果是偶数就和跟结点性别相同。我用r[x]记录x与其父亲节点的关系, r[x]=0表同性, rank[x]=1表异性。

扫描二维码关注公众号,回复: 4307255 查看本文章

代码:

#include<stdio.h>
int f[2020],r[2020],n,m;
void init()
{
	int i;
	for(i=1;i<=n;i++)
		f[i]=i;
	return;
}
int getf(int v)
{
	int t;
	if(f[v]==v)
		return v;
	else
	{
		t=f[v];
		f[v]=getf(f[v]);
		r[v]=(r[v]+r[t]+1)%2;
	}	
	return f[v];
}
void merge(int x,int y)
{
	int t1,t2;
	t1=getf(x);
	t2=getf(y);
	if(t1!=t2)
	{
		f[t2]=t1;
	}
	r[t2]=(r[y]-r[x])%2;
}
int main()
{
	int t,i,a,b,flag,c;
	scanf("%d",&t);	
	c=1;
	while(t--)
	{
		flag=0;
		scanf("%d%d",&n,&m);
		init();
		for(i=1;i<=n;i++)
			r[i]=1;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&a,&b);
			if(getf(a)==getf(b))
			{
				if(r[a]==r[b])    //说明性别相同
					flag=1;
			}
			else
				merge(a,b);
		}
		if(flag)
			printf("Scenario #%d:\nSuspicious bugs found!\n\n",c++);
		else
			printf("Scenario #%d:\nNo suspicious bugs found!\n\n",c++);
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/wan_ide/article/details/81477430