Crossword Answers

A crossword puzzle consists of a rectangular grid of black and
white squares and two lists of definitions (or descriptions).
One list of definitions is for “words” to be written left to
right across white squares in the rows and the other list is for
words to be written down white squares in the columns. (A
word is a sequence of alphabetic characters.)
To solve a crossword puzzle, one writes the words corresponding to the definitions on the white squares of the grid.
The definitions correspond to the rectangular grid by
means of sequential integers on “eligible” white squares.
White squares with black squares immediately to the left or
above them are “eligible.” White squares with no squares either immediately to the left or above are also “eligible.” No other squares are numbered. All of the
squares on the first row are numbered.
The numbering starts with 1 and continues consecutively across white squares of the first row, then
across the eligible white squares of the second row, then across the eligible white squares of the third
row and so on across all of the rest of the rows of the puzzle. The picture below illustrates a rectangular
crossword puzzle grid with appropriate numbering.
An “across” word for a definition is written on a sequence of white squares in a row starting on a
numbered square that does not follow another white square in the same row.
The sequence of white squares for that word goes across the row of the numbered square, ending
immediately before the next black square in the row or in the rightmost square of the row.
A “down” word for a definition is written on a sequence of white squares in a column starting on a
numbered square that does not follow another white square in the same column.
The sequence of white squares for that word goes down the column of the numbered square, ending
immediately before the next black square in the column or in the bottom square of the column.
Every white square in a correctly solved puzzle contains a letter.
You must write a program that takes several solved crossword puzzles as input and outputs the lists
of across and down words which constitute the solutions.
Input
Each puzzle solution in the input starts with a line containing two integers r and c (1 ≤ r ≤ 10 and
1 ≤ c ≤ 10), where r (the first number) is the number of rows in the puzzle and c (the second number)
is the number of columns.
The r rows of input which follow each contain c characters (excluding the end-of-line) which describe
the solution. Each of those c characters is an alphabetic character which is part of a word or the
character ‘’, which indicates a black square.
The end of input is indicated by a line consisting of the single number ‘0’.
Output
Output for each puzzle consists of an identifier for the puzzle (puzzle #1:, puzzle #2:, etc.) and the
list of across words followed by the list of down words. Words in each list must be output one-per-line
in increasing order of the number of their corresponding definitions.
The heading for the list of across words is ‘Across’. The heading for the list of down words is ‘Down’.
In the case where the lists are empty (all squares in the grid are black), the ‘Across’ and ‘Down’
headings should still appear.
Separate output for successive input puzzles by a blank line.
Sample Input
2 2
AT
O
6 7
AIM
DEN
MEONE
UPON
TO
SOERIN
SAOR

IESDEA
0
Sample Output
puzzle #1:
Across
1.AT
3.O
Down
1.A
2.TO
puzzle #2:
Across
1.AIM
4.DEN
7.ME
8.ONE
9.UPON
11.TO
12.SO
13.ERIN
15.SA
17.OR
18.IES
19.DEA
Down
1.A
2.IMPOSE
3.MEO
4.DO
5.ENTIRE
6.NEON
9.US
10.NE
14.ROD
16.AS
18.I
20.A
代码
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<ctype.h>
struct Across
{
int x;
int y;
int num;
}across[77];
struct Down
{
int x;
int y;
int num;
}down[77];
char a[17][17];
int b[17][17];
int main()
{
int m,n,i,j,count=1,num1,k1,k2;
while(scanf("%d",&m)!=EOF&&m!=0)
{
//input
scanf("%d",&n);
getchar();
for(i=0;i<m;i++)
scanf("%s",a[i]);
//1
for(i=0;i<m;i++)
for(j=0;j<n;j++)
{
if(isalpha(a[i][j]))
{
if(i0||j0)
b[i][j]=1;
else if(a[i-1][j]==’
’||a[i][j-1]’*’)
b[i][j]=1;
}
}
//2
num1=0;
k1=0;
k2=0;
for(i=0;i<m;i++)
for(j=0;j<n;j++)
{
if(b[i][j]1)
{
num1++;
if(j
0||a[i][j-1]
’)
{
across[k1].x=i;
across[k1].y=j;
across[k1].num=num1;
k1++;
}
if(i0||a[i-1][j]
’)
{
down[k2].x=i;
down[k2].y=j;
down[k2].num=num1;
k2++;
}
}
}
//output
if(count!=1)
printf("\n");
printf(“puzzle #%d:\n”,count);
count++;
printf(“Across\n”);
for(i=0;i<k1;i++)
{
printf("%3d.",across[i].num);
for(j=0;;j++)
{
printf("%c",a[across[i].x][across[i].y+j]);
if(across[i].y+jn-1)
break;
if(a[across[i].x][across[i].y+j+1]
’)
break;
}
puts("");
}
printf(“Down\n”);
for(i=0;i<k2;i++)
{
printf("%3d.",down[i].num);
for(j=0;;j++)
{
printf("%c",a[down[i].x+j][down[i].y]);
if(down[i].x+jm-1)
break;
if(a[down[i].x+j+1][down[i].y]
’)
break;
}
puts("");
}
//zero
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
}
}

猜你喜欢

转载自blog.csdn.net/weixin_43797508/article/details/86174486