C - A Plug for UNIX(最大流+STL)

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible.
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can.
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn’t exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug.
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.
Input
The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.
Output
A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.
Sample Input
4
A
B
C
D
5
laptop B
phone C
pager B
clock B
comb X
3
B X
X A
X D
Sample Output
1
题目大意是联合国开会时各个国家的记者携带了不同的电器,每个电器只有插入对应的插座才能供电,酒店房间供应了几个不同插座,而商店可以买到几种插座的转换器并且不限量购买,题目问最少有几个设备无法供电。

问最少有几个设备,即设备总数减去最大流,首先将设备连接源点,容量为1,再将第一次给出的插座连接汇点,容量为1。再将设备连接对应的插座,容量为1,最后根据转换器连接各个插座,容量为无限(因为转换器无限供应),然后跑最大流。
由于给出的数据都是以字符串形式,所以用map存放

#include<stdio.h>
#include<iostream>
#include<cmath>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=1e4+5;
const int maxm=1e5+5;
int n,m,S,T,ne,head[maxn],cur[maxn],depth[maxn],maxflow,num1,num2,k;
map<string,int> M;
queue<int> q;
struct edge
{
	int next,to,cost;
}e[maxm*2];
void init()
{
	memset(head,-1,sizeof(head));
	ne=0;
	maxflow=0;
	M.clear();
	num1=0;
	num2=0;
}
void add(int u,int v,int w)
{
	e[ne].to=v;
	e[ne].cost=w;
	e[ne].next=head[u];
	head[u]=ne++;
	e[ne].to=u;
	e[ne].cost=0;
	e[ne].next=head[v];
	head[v]=ne++;
}
int bfs(int s,int t)
{
	while(!q.empty()) q.pop();
	memset(depth,-1,sizeof(depth));
	for(int i=0;i<=T;i++) cur[i]=head[i];
	depth[s]=0;
	q.push(s);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		for(int i=head[u];i!=-1;i=e[i].next)
		{
			if(depth[e[i].to]==-1&&e[i].cost)
			{
				depth[e[i].to]=depth[u]+1;
				q.push(e[i].to);
			}
		}
	}
	if(depth[t]==-1) return -1;
	else return 1;
}
int dfs(int s,int t,int limit)
{
	if(!limit||s==t) return limit;
	int f,flow=0;
	for(int i=cur[s];i!=-1;i=e[i].next)
	{
		cur[s]=i;
		if(depth[e[i].to]==depth[s]+1&&(f=dfs(e[i].to,t,min(limit,e[i].cost))))
		{
			flow+=f;
			limit-=f;
			e[i].cost-=f;
			e[i^1].cost+=f;
			if(!limit) break;
		}
	}
	return flow;
}
void dinic(int s,int t)
{
	while(bfs(s,t)!=-1)
	{
		maxflow+=dfs(s,t,INF);
	}
}
int main()
{
	while(~scanf("%d",&n))
	{
		S=0;
		T=301;
		init();
		for(int i=0;i<n;i++)
		{
			char str[30];
			scanf("%s",str);
			M[str]=++num1;
			add(M[str],T,1);
		}
		scanf("%d",&m);
		for(int i=0;i<m;i++)
		{
			char str1[30],str2[30];
			scanf("%s %s",str1,str2);
			M[str1]=++num2+200;
			add(S,M[str1],1);
			if(M[str2]) add(M[str1],M[str2],1);
			else
			{
				M[str2]=++num1;
				add(M[str1],M[str2],1);
			}
		}
		scanf("%d",&k);
		for(int i=0;i<k;i++)
		{
			char str1[30],str2[30];
			scanf("%s %s",str1,str2);
			if(!M[str1]) M[str1]=++num1;
			if(!M[str2]) M[str2]=++num1;
			add(M[str1],M[str2],INF);
		}
		dinic(S,T);
		printf("%d\n",m-maxflow);
	}
}

猜你喜欢

转载自blog.csdn.net/zufe_cst/article/details/86482929