POJ-Oil Deposits(dfs)

Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

题目链接:

http://poj.org/problem?id=1562

题意描述:

给你一个图,有m行n列,然后问该图有多少个用“@”连一块的图

解题思路:

把这个图存到一个字符数组里,构造一个矩阵,然后深搜逐个判断是否是"@"如果是把“@”改成“*"继续搜索,直到整个图搜完

程序代码:

#include<stdio.h>
#include<string.h>

char str[110][110];
int m,n;
void dfs(int x,int y);

int main()
{
	int i,j,count;
	while(scanf("%d%d",&m,&n),m!=0||n!=0)
	{
		count=0;
		for(i=0;i<m;i++)
			scanf("%s",str[i]);
		for(i=0;i<m;i++)
			for(j=0;j<n;j++)
				if(str[i][j]=='@')
				{
					count++;
					dfs(i,j);					
				}	 
		printf("%d\n",count);
	}	
	return 0;
} 
void dfs(int x,int y)
{
	int next[8][2]={0,1, 0,-1, 1,0, -1,0, 1,1, 1,-1, -1,1, -1,-1};
	int tx,ty,i;
	str[x][y]='*';
	for(i=0;i<8;i++)
	{
		tx=x+next[i][0];
		ty=y+next[i][1];
		if(tx<0||tx>m-1||ty<0||ty>n-1)
			continue;
		if(str[tx][ty]=='@')
			dfs(tx,ty);
	}
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/86539514