pat a1046

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10
​5
​​ ]), followed by N integer distances D
​1
​​ D
​2
​​ ⋯ D
​N
​​ , where D
​i
​​ is the distance between the i-th and the (i+1)-st exits, and D
​N
​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10
​4
​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10
​7
​​ .

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:

3
10
7

代码
#include<stdio.h>
#include<string.h>
int main()
{
int n,m;
int qi,zhi;
int s=0;
scanf("%d “,&n);
int dis[n];
int d[n];
int tmp;
int i,j;
int k;
int juli[n];
memset(dis,0,sizeof(dis));
memset(d,0,sizeof(d));
memset(juli,0,sizeof(juli));
for(i=0;i<n;i++)
{
scanf(”%d",&d[i]);
dis[i]=s;
s+=d[i];
}
scanf("%d",&m);
for(i=0;i<m;i++)
{
scanf("%d%d",&qi,&zhi);
if(zhi<qi)
{
tmp=zhi;
zhi=qi;;
qi=tmp;

}

juli[i]=dis[zhi-1]-dis[qi-1];
if(s-juli[i]<juli[i])
juli[i]=s-juli[i];

}
for(k=0;k<m;k++)
{

printf("%d\n",juli[k]);

}
return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41474792/article/details/86550848