I - Proud Merchants 题解

Time limit   1000 ms

Memory limit    65536 kB

OS    Windows

1.题目:

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more. 
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi. 
If he had M units of money, what’s the maximum value iSea could get? 

2.Input:

There are several test cases in the input. 

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money. 
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description. 

The input terminates by end of file marker. 

3.output:

For each test case, output one integer, indicating maximum value iSea could get. 

Sample Input

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

Sample Output

5
11

分析:本题为01背包的另一种考法,唯一不同的是需要排序,比如当a和b都能购买的时候,优先选择p+q更小的,可以使背包能容纳的价值最大。

代码如下:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define max(a,b) a>b?a:b
#define MAX 5005    //注意数据范围
using namespace std;
struct node {
    int p,q,v;
}item[MAX];

bool cmp(node a,node b){          
    return a.q-a.p<b.q-b.p;
}
int main() {
    int n,m,dp[MAX]; 
    while(~scanf("%d %d",&n,&m)){
        memset(dp,0, sizeof(dp));
        for(int i=0;i<n;i++)
            scanf("%d %d %d",&item[i].p,&item[i].q,&item[i].v);

        sort(item,item+n,cmp);    //对数据进行按q-p从小到大的顺序排序
        for(int i=0;i<n;i++){     //01背包问题
            for(int j=m;j>=item[i].q;j--){
                dp[j]=max(dp[j],dp[j-item[i].p]+item[i].v);
            }
        }
        printf("%d\n",dp[m]);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43301061/article/details/85555512