POJ - 1679 The Unique MST (最小生成树MST)

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

题意:判断是不是只有一棵最小生成树,如果是输出权值和,如果不是输出Not Unique!,输入的边没有重复

题解:判断是不是有圈即可,详细见代码:

#include <iostream>
#include <algorithm>
using namespace std;
const int MAX = 1e6;
struct hh{
	int u,v,w;
}a[MAX];
int f[MAX];
int n,m;
int find(int x){
	return f[x]==x? x:f[x]=find(f[x]);
}
//void lianjie(int u,int v){
//	int root1=find(u);
//	int root2=find(v);
//	if(root1!=root2) f[root1]=root2;
//}
bool cmp(hh a,hh b){
	return a.w<b.w;
}
int main(){
	int t;
	cin >> t;
	while(t--){
		cin >> n >> m;
		for (int i = 1; i <= n;i++) f[i]=i;
		for (int i = 0; i < m;i++){
			cin >> a[i].u >> a[i].v >> a[i].w;
		}
		sort(a,a+n,cmp);
		int cnt;
		int love=0;
		int sum=0;
		int ans=0;
		for (int i = 0; i < m;){
			cnt=i;
			while(a[i].w==a[cnt].w&&cnt<m){//判断是不是有圈
				int root1=find(a[cnt].u);
				int root2=find(a[cnt].v);
				if(root1!=root2) love++;//有圈的话这个love>ans这是下面最小生成树的边的数量
				cnt++;
			}
			cnt=i;
			while(a[i].w==a[cnt].w&&cnt<m){//建最小生成树
				int root1=find(a[cnt].u);
				int root2=find(a[cnt].v);
				if(root1!=root2){
					ans++;
					sum+=a[i].w;
					f[root1]=root2;
				}
				cnt++;
			}
			i=cnt;
			if(ans==n-1) break;
		}
		if(love>ans) cout << "Not Unique!" << endl;//如果有圈,就不唯一
		else cout << sum << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/lgz0921/article/details/85057844