UVA10600:ACM Contest and Blackout(次小生成树)

ACM Contest and Blackout

题目链接:https://vjudge.net/problem/UVA-10600

Description:

In order to prepare the “The First National ACM School Contest” (in 20??) the major of the city decided to provide all the schools with a reliable source of power. (The major is really afraid of blackoutsJ). So, in order to do that, power station “Future” and one school (doesn’t matter which one) must be connected; in addition, some schools must be connected as well. You may assume that a school has a reliable source of power if it’s connected directly to “Future”, or to any other school that has a reliable source of power. You are given the cost of connection between some schools. The major has decided to pick out two the cheapest connection plans – the cost of the connection is equal to the sum of the connections between the schools. Your task is to help the major — find the cost of the two cheapest connection plans.

Input:

The Input starts with the number of test cases, T (1 < T < 15) on a line. Then T test cases follow. The first line of every test case contains two numbers, which are separated by a space, N (3 < N < 100) the number of schools in the city, and M the number of possible connections among them. Next M lines contain three numbers Ai , Bi , Ci , where Ci is the cost of the connection (1 < Ci < 300) between schools Ai and Bi . The schools are numbered with integers in the range 1 to N.

Output:

For every test case print only one line of output. This line should contain two numbers separated by a single space – the cost of two the cheapest connection plans. Let S1 be the cheapest cost and S2 the next cheapest cost. It’s important, that S1 = S2 if and only if there are two cheapest plans, otherwise S1 < S2. You can assume that it is always possible to find the costs S1 and S2.

Sample Input:

2

5 8

1 3 75 3 4 51 2 4 19 3 2 95 2 5 42 5 4 31 1 2 9 3 5 66

9 14

1 2 4 1 8 8 2 8 11 3 2 8 8 9 7 8 7 1 7 9 6 9 3 2 3 4 7 3 6 4 7 6 2 4 6 14 4 5 9 5 6 10

Sample Output:

110 121

37 37

题意:

求次小生成树。

题解:

先跑一遍最小生成树,然后O(n^2)预处理出任意两点之间的最小瓶颈路,最后通过枚举算出次小生成树。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#include <cmath>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int N = 105;
int t,n,m;
struct Edge{
    int u,v,w;
    bool operator < (const Edge &A)const{
        return w<A.w;
    }
}e[N*N];
int f[N],mp[N][N];
int find(int x){
    return f[x]==x?f[x]:f[x]=find(f[x]);
}
int Kruskal(){
    int ans=0;
    for(int i=0;i<=n+1;i++) f[i]=i;
    for(int i=1;i<=m;i++){
        int u=e[i].u,v=e[i].v;
        int fx=find(u),fy=find(v);
        if(fx==fy) continue ;
        f[fx]=fy;
        mp[u][v]=mp[v][u]=1;
        ans+=e[i].w;
    }
    return ans ;
}
int d[N][N],dis[N][N];
int check[N];
void dfs(int u,int fa){
    for(int i=1;i<=n;i++){
        if(check[i]) d[i][u]=d[u][i]=max(d[i][fa],dis[u][fa]);
    }
    check[u]=1;
    for(int i=1;i<=n;i++){
        if(mp[i][u] && i!=fa) dfs(i,u);
    }
}
int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        memset(dis,0,sizeof(dis));
        for(int i=1;i<=m;i++){
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            e[i]=Edge{u,v,w};
            dis[u][v]=dis[v][u]=w;
        }
        sort(e+1,e+m+1);
        memset(d,0,sizeof(d));
        memset(check,0,sizeof(check));
        memset(mp,0,sizeof(mp));
        int sum=Kruskal();
        cout<<sum<<" ";
        dfs(1,-1);
        int ans=INF;
        for(int i=1;i<=m;i++){
            int u=e[i].u,v=e[i].v,w=e[i].w;
            if(mp[u][v]) continue ;
            ans=min(ans,sum-d[u][v]+w);
        }
        cout<<ans<<endl;
    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/heyuhhh/p/10372305.html