Round Numbers POJ - 3252

Round Numbers

 POJ - 3252 

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive rangeStart.. Finish

Sample Input

2 12

Sample Output

6

题目大意:

输入两个数A,B 求在这个区间内,将数字转换成2进制后0大于等于1的数字的数量

代码:

#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;

int dp[33][66];
int a[66];

int dfs(int pos,int num,int lead,int limit){
	if(pos<=-1) return num>=32;
	if(!lead && !limit && dp[pos][num]!=-1) return dp[pos][num];
	
	int up = limit?a[pos]:1;
	int res =0;
	for(int i=0;i<=up;i++){
		if(lead&& i==0) res +=dfs(pos-1,num,lead,limit && i==a[pos]);
		else res+=dfs(pos-1,num+(i==0?1:-1),lead&& i==0,limit && i==a[pos]);
	}
	
	if(!limit && !lead) dp[pos][num] = res;
	return res;
}

int solve(int x){
	int pos = 0;
	while(x>0){
		a[pos++] = x&1;
		x=x>>1;
	}
	int res = dfs(pos-1,32,true,true);	
	return res;
}
int main(){
	
	int A,B;
	memset(dp,-1,sizeof(dp));
	scanf("%d %d",&A,&B);
	
	printf("%d\n",solve(B)-solve(A-1));
	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/Willen_/article/details/86767671