洛谷P1118 [USACO06FEB]数字三角形

版权声明:转载请注明出处 https://blog.csdn.net/qq_41431457/article/details/88892331

题目描述

FJ and his cows enjoy playing a mental game. They write down the numbers from 11 toN(1 \le N \le 10)N(1≤N≤10)in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4N=4) might go like this:

    3   1   2   4
      4   3   6
        7   9
         16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number NN. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.

有这么一个游戏:

写出一个11至NN的排列a_iai​,然后每次将相邻两个数相加,构成新的序列,再对新序列进行这样的操作,显然每次构成的序列都比上一次的序列长度少11,直到只剩下一个数字位置。下面是一个例子:

3,1,2,43,1,2,4

4,3,64,3,6

7,97,9

1616

最后得到1616这样一个数字。

现在想要倒着玩这样一个游戏,如果知道NN,知道最后得到的数字的大小sumsum,请你求出最初序列a_iai​,为11至NN的一个排列。若答案有多种可能,则输出字典序最小的那一个。

[color=red]管理员注:本题描述有误,这里字典序指的是1,2,3,4,5,6,7,8,9,10,11,121,2,3,4,5,6,7,8,9,10,11,12

而不是1,10,11,12,2,3,4,5,6,7,8,91,10,11,12,2,3,4,5,6,7,8,9[/color]

输入输出格式

输入格式:

两个正整数n,sumn,sum。

输出格式:

输出包括11行,为字典序最小的那个答案。

当无解的时候,请什么也不输出。(好奇葩啊)

输入输出样例

输入样例#1: 复制

4 16

输出样例#1: 复制

3 1 2 4

说明

对于40\%40%的数据,n≤7n≤7;

对于80\%80%的数据,n≤10n≤10;

对于100\%100%的数据,n≤12,sum≤12345n≤12,sum≤12345。


刚开始是一层一层的往下搜的,结果tle,看了一下大佬的思路:在n个数字变成一个数字的过程中,必定会有中间的数重复加很多次,至于具体哪些数加了多少次,正好符合杨辉三角的规律,可以用笔模拟一下,例如样例:3 1 2 4 这四个数分别加了1 3 3 1次,所以问题就可以转化为枚举一个数列,使得他的和等于一个树:

code:

#include<bits/stdc++.h>
using namespace std;
int a[15][15],ans[15],N,T;
bool vis[15],flag=0;
void init()//杨辉三角初始化 
{
	for(int i=1;i<=15;i++) a[i][1]=a[i][i]=1;
	for(int i=3;i<=15;i++) 
	for(int j=2;j<i;j++) a[i][j]=a[i-1][j-1]+a[i-1][j];
}
void deep(int n,int sum)//第n个数,总和是多少 
{
	if(flag==1||sum>T) return ;
	if(n==N+1&&sum==T)
	{
		for(int i=1;i<=N;i++) cout<<ans[i]<<' ';
		flag=1;	return ;
	}
	for(int i=1;i<=N;i++)
	if(vis[i]==0)
	{
		vis[i]=1;
		ans[n]=i;
		deep(n+1,sum+i*a[N][n]);
		vis[i]=0;
	}
}
int main()
{
	init();
	cin>>N>>T;
	deep(1,0);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41431457/article/details/88892331