并查集+贪心——基础并查集

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 
Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.


题意: 超市每个商品 对应有 利润和销售日期两个数据,每天只能销售一件商品,所以 利用并查集将销售日期相同的放在一起,然后利润排序,筛选最大利润,最后相加即可;


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<cmath>
#include<stack>
using namespace std;
struct node
{
    int pi;
    int di;
}mapp[10010];
int par[10010];
bool cmp(node x, node y)
{
    //如果两个产品的利润相同,则返回销售日期较大的那个;否则返回利润大的那个;
    if(x.pi==y.pi)
    {
        return x.di>y.di;
    }
    else
        return x.pi>y.pi;
}
//初始化n个元素;
void init(int n)
{
    for(int i=0; i<=n; i++)
    {
        par[i] = i;
    }
}
//查询树的根;
int find(int x)
{
    if(par[x]==x)
        return x;
    else
    {
        return par[x] = find(par[x]);
    }
}
int main()
{
    int n;
    while(scanf("%d", &n)!=EOF)
    {
        int maxx = 0;
        int sum = 0;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d", &mapp[i].pi, &mapp[i].di);
            maxx = max(maxx, mapp[i].di);//找到最大的截止日期;
        }
        init(maxx);
        sort(mapp, mapp+n, cmp);//利润相同,销售日期大的在前,利润不同,利润大的在前;
        //
        for(int i=0; i<n; i++)
        {
            for(int j=mapp[i].di; j>0; )
            {
                if(par[j]==j)//如果par[j]=j,即说明j为所在树的根,如果相同销售日期利润较小的那个通过连接相同日期的根,且根大于0,说明,该产品可以在其根上那一天消售;
                {
                    par[j] = find(j-1);//令j的根为j-1的根,将销售日期大的放在销售日期小的下面(合并);
                    sum+=mapp[i].pi;
                    break;
                }
                else//否则,即说明在该销售日期内,有利润比其大的产品,将其连接到与他相同日期的根上;
                    j = find(j);
            }
        }
        printf("%d\n",sum);
    }
}

补充:

假设案例为:7  20 1  1 10  10 3  100 2  8 2  5 20  50 10

则排完序为

di:  2     10     1     3     2     20     10

pi:100   50    20    10    8     5       1

具体过程如下所示:

猜你喜欢

转载自blog.csdn.net/qq_42569807/article/details/88897262
今日推荐