PAT(甲级)1019 General Palindromic Number (20 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

简析:这道题一开始没看清题目,就直接将数转化成对应字符串型,题目里面的意思可能考虑到10进制以上的时候,输出的结果可能不是一个一个输出,是对应的部分还是输出可能多位数,不是只输出一位数。

#include<iostream>
using namespace std;
int main()
{
    int n, b;
    cin >> n >> b;
    int arr[40], index = 0;
    while(n!=0)
    {

        arr[index++] = n % b;
        n = n / b;
    }
    bool flag = 1;
    for (int i = 0; i < index / 2;i++)
    {
        if(arr[i] != arr[index-1-i])
            flag = 0;
    }
    if(flag == 0)
        cout << "No" << '\n';
    else
        cout << "Yes" << '\n';
    cout << arr[index- 1];
    if(index>1)
    {
        for (int i = index - 2; i >=0;i--)
            cout << ' ' << arr[i];
    }
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35601980/article/details/89297271