[PYTHON](PAT)1019 GENERAL PALINDROMIC NUMBER (20)

版权声明:首发于 www.amoshuang.com https://blog.csdn.net/qq_35499060/article/details/82077547

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

题目大意

给定一个十进制下的整数N以及一个基数b。

如果N转换成b进制是回文数,则输出Yes,否则则输出No。最终都要输出N转换到b进制后的数,用空格隔开。

分析

首先将转换后的数的每一个组成部分用数组存储起来,遍历这个数组判断是否是回文数。

注意!这个转换后的数的每一部分不一定在[0-9],考虑2356 42这个测试用例,答案应该是No 1 14 4。

Python实现

def change(n,radix):
    if n==0:
        return '0'
    result = []
    while(n != 0):
        result.insert(0, str(n % radix))
        n = n//radix
    return result

if __name__ =="__main__":
    line = input().split(" ")
    n = int(line[0])
    radix = int(line[1])
    num = change(n, radix)
    result = ''
    if len(num) == 1:
        result = "Yes" +"\n" + num[0]
    else:
        for x in range(len(num)//2):
            if num[x] != num[len(num) - 1-x]:
                result = "No"+"\n"+" ".join(num)
                break
        if result == '':
            result = "Yes" + "\n" +" ".join(num)
    print(result)

更多技术干货,有趣文章,点这里没错

猜你喜欢

转载自blog.csdn.net/qq_35499060/article/details/82077547