PAT 1019 General Palindromic Number python解法

1019 General Palindromic Number (20 分)
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i as ∑​k​i=0 (a​ib​i ). Here, as usual, 0≤a​i<b for all i and a​k is non-zero. Then N is palindromic if and only if a​i = a​k−i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:
For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form “a​k​​ a​k-1​​ … a0​​”. Notice that there must be no extra space at the end of output.

Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1

题意:将一个十进制数转换为其他进制数,判断是否为回文数字并输出转换结果。如:给出27 2,先将27转换为2进制11011,判断为回文,输出Yes,并在下一行输出1 1 0 1 1。

解题思路:用一个函数来转换进制,最简单的就是辗转相除取余。判断是否是回文数字可以将列表倒序后与原列表比较,如果两个列表相同则是回文,不同则不是,也可以比较前半部分和后半部分是否相同来判断回文。最后按题给格式输出。

n, b = input().split()
n, b = int(n), int(b)
def transform(num, base):
    out = []
    while num >= base:
        out.append(num%base)
        num = num//base
    out.append(num)
    return out
out = transform(n,b)
if out[::-1] == out:
    print('Yes')
else:
    print('No')
out = [str(i) for i in out[::-1]]
print(' '.join(out))

猜你喜欢

转载自blog.csdn.net/qq_36936510/article/details/86504500