hdu1907尼姆博弈先取光输

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 6527    Accepted Submission(s): 3759


 

Problem Description

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

 

Input

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 

 

Output

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.
 

 

Sample Input

 

2 3 3 5 1 1 1

 

Sample Output

 

John Brother

 

Source

Southeastern Europe 2007

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1913 1908 1914 1915 1909 

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int t;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int x;
        int ans=0,sum=0;
        for(int i=1;i<=n;i++)
            {scanf("%d",&x);
            if(x>1)
                sum++;

            ans^=x;


    }
    if((ans==0&&sum==0)||(ans!=0&&sum>0))
        printf("John\n");
    else
        printf("Brother\n");
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89480015