HDU-1907-John(尼姆博弈)

John

Problem Description

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

Input

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

Output

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

Sample Input

2
3
3 5 1
1
1
 

Sample Output

John
Brother

解题思路:

简单尼姆博弈,需要特殊处理的是全为1的情况。

AC代码:

#include <iostream>
#include <cmath>
using namespace std;
typedef long long ll;
const int mod =  1e9 + 7;
const int N = 1e6+10;
int a[N];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        int res = 0;
        int cnt = 0;
        for(int i = 0 ; i < n ; i ++)
        {
            cin>>a[i];
            if(a[i] == 1)
                cnt ++;
            res ^= a[i];
        }
        if (cnt == n)
        {
            if(cnt%2 == 0)
                cout<<"John"<<endl;
            else
                cout<<"Brother"<<endl;
        }
        else if(res)
            cout<<"John"<<endl;
        else
            cout<<"Brother"<<endl;
    }
}
发布了104 篇原创文章 · 获赞 7 · 访问量 4103

猜你喜欢

转载自blog.csdn.net/qq_43461168/article/details/103073559