Matrix [STL]Priority Queue (eden) POJ 3125

Descrption

The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output.

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, and 1 being the lowest), and the printer operates as follows.

The first job J in queue is taken from the queue.
If there is some job in the queue with a higher priority than job J, then move J to the end of the queue without printing it.
Otherwise, print job J (and do not put it back in the queue).
In this way, all those important muffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life.

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplify matters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input Format

One line with a positive integer: the number of test cases (at most 20). Then for each test case:

  • One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 50) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
  • One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output Format

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Input Sample

3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1

Output Sample

1
2
5

Requirement:Try to use priority queue.

本题的目的是一个优先队列的练习.
此题的思路(使用优先队列)为:声明一个双向队列(deque)和一个优先队列(priority queue),然后从deque的第一个元素到第position个元素,每次将deque的队首元素与priority queue的队首元素比较,如果前者不小于后者,则print(deque和priority queue都pop掉队首),time++;反之则将
deque的队首元素push到队尾并pop在队首的它.直到第position个元素被print,输出time.然而,如果第position个元素被push到队尾,则将循环重新回到deque的第一个元素到第deque.size()-1个元素.
核心代码实现如下:
for (int k = 0; k <= position; k++) {
            if (dq.front() >= pq.top()) {
                dq.pop_front();
                pq.pop();
                time++;
            }
            else {
                dq.push_back(dq.front());
                dq.pop_front();
                if (k == position) {
                    k = 0;
                    position = dq.size();
                }
            }
        }
 

其中dq指的是deque,pq指的是priority queue

然而,有一些细节(被坑了的教训)需要注意到:
1.每一轮打印都要将time置为0
2.每一轮打印都要将deque和priority queue清空
清空时,我原来是这样写的:
dq.clear(); 
for(int e=0;e<pq.size();e++){
    pq.pop();        
}
 

大家可能已经发现了:

每次pq.pop()后pq.size()已经改变了!!!!

所以应该先将清空前的pq.size()储存起来,再循环

即:

int tmp=pq.size();
dq.clear(); 
for(int e=0;e<tmp;e++){
    pq.pop();        
}

不过我还是使用了while大法(while大法好啊)

dq.clear();
while (!pq.empty())
    pq.pop();

完整代码如下:

#include<iostream>
#include<queue>
#include<deque>
using namespace std;
int main() {
    int n;
    int num;
    int position;
    int temp;
    int time = 0;
    deque<int> dq;
    priority_queue<int> pq;
    cin >> n;
    for (int i = 0; i < n; i++) {
        cin >> num >> position;
        for (int j = 0; j < num; j++) {
            cin >> temp;
            dq.push_back(temp);
            pq.push(temp);
        }
        for (int k = 0; k <= position; k++) {
            if (dq.front() >= pq.top()) {
                dq.pop_front();
                pq.pop();
                time++;
            }
            else {
                dq.push_back(dq.front());
                dq.pop_front();
                if (k == position) {
                    k = 0;
                    position = dq.size();
                }
            }
        }
        cout << time << endl;
        dq.clear();
        while (!pq.empty())
            pq.pop();
        time = 0;
    }
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/CrossingX/p/10991036.html
今日推荐