【基础】A + B Again

描述

There must be many A + B problems in our TOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

输入

The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

输出

For each test case,print the sum of A and B in hexadecimal in one line.

样例输入

+A -A
+1A 12
1A -9
-1A -12
1A -AA

样例输出

0
2C
11
-2C
-90

题目来源

HDOJ

收获:
%I64X 64位16进制数
代码:
#include<bits/stdc++.h>
using namespace std;
int main()
{
long long a,b;
while(scanf("%I64X%I64X",&a,&b)!=EOF)
{
long long c=a+b;
if (c>=0)
{
printf("%I64X\n",c);
}
else
{
printf("-%I64X\n",~c+1);
}
}
return 0;
}

发布了69 篇原创文章 · 获赞 0 · 访问量 1875

猜你喜欢

转载自blog.csdn.net/Skynamer/article/details/104069390