1094 The Largest Generation (25分)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

树的层序遍历

源码:

#include <bits/stdc++.h>
using namespace std;
#define Max 100
vector<int> node[Max];
deque<int> que;
int main() {
    int M,N;
    cin>>N>>M;
    for(int i=0;i<M;i++)
    {
        int parent,n;
        cin>>parent>>n;
        for(int j=0;j<n;j++)
        {
            int x;cin>>x;
            node[parent].push_back(x);
        }
    }
    que.push_back(-1);
    que.push_front(1);
    int level=1;
    int count=0;
    int max=-1;
    int max_lev=-1;
    while(!que.empty())
    {
        int t=que.front();
        que.pop_front();
        if(t==-1)
        {
            level++;
            count=0;
            if(que.empty())
                break;
            que.push_back(-1);
            continue;
        }
        count++;
        if(count>max)
        {
            max=count;
            max_lev=level;
        }
        for(int i=0;i<node[t].size();i++)
        {
            que.push_back(node[t][i]);
        }
    }

    cout<<max<<" "<<max_lev<<endl;
    return 0;
}
发布了97 篇原创文章 · 获赞 12 · 访问量 2405

猜你喜欢

转载自blog.csdn.net/weixin_43301333/article/details/104069726
今日推荐