1094 The Largest Generation

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4

分析:家谱通常由树状结构描述,有根结点和孩子结点。现在要求人数最多的一代,和相应的人数。
dfs深度优先搜索,并且记录层次。
参考代码:

#include<vector>
#include<iostream>
#include<cstdio>
using namespace std;
vector<vector<int>>graph;
vector<int>gen;
vector<bool>visited;
void bfs(int v, int depth) {
    visited[v] = true;
    gen[depth]++;
    for (int i = 0; i < graph[v].size(); i++) {
        if (!visited[graph[v][i]])
            bfs(graph[v][i], depth + 1);
    }
}
int main()
{

    int n, m;
    scanf("%d%d", &n, &m);

    graph.resize(n + 1);
    gen.resize(n + 1,0);
    visited.resize(n + 1, false);
    int v, k, child;
    for (int i = 1; i <= m; i++) {
        scanf("%d%d", &v, &k);
        if (k) {
            for (int j = 1; j <= k; j++) {
                scanf("%d", &child);
                graph[v].push_back(child);
            }
        }
    }

    bfs(1, 1);
    int index = 1, max = 0;
    for (int i = 1; i <= n; i++) {
        if (gen[i] > max) {
            max = gen[i];
            index = i;
        }
    }
    cout << max << " " << index;

    return 0;
}

还有另外一种解题方式(来自他人),就是bfs(广度优先搜索)。记录每一结点的层次,那么其孩子结点的层次是父节点所在层次加1。
参考代码

#include<vector>
#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
vector<vector<int>>graph;
vector<int>gen;
vector<int>level;
vector<bool>visited;

int main()
{

    int n, m;
    scanf("%d%d", &n, &m);

    graph.resize(n + 1);
    gen.resize(n + 1, 0);
    visited.resize(n + 1, false);
    level.resize(n + 1);
    level[1] = 1;
    int v, k, child;
    for (int i = 1; i <= m; i++) {
        scanf("%d%d", &v, &k);
        if (k) {
            for (int j = 1; j <= k; j++) {
                scanf("%d", &child);
                graph[v].push_back(child);
            }
        }
    }

    queue<int>q;
    q.push(1);
    while (!q.empty())
    {
        int v = q.front();
        q.pop();
        gen[level[v]]++;
        visited[v] = true;
        for (int i = 0; i < graph[v].size(); i++) {
            if (!visited[graph[v][i]]) {
                level[graph[v][i]] = level[v] + 1;
                q.push(graph[v][i]);
            }
        }
    }

    int index = 1, max = 0;
    for (int i = 1; i <= n; i++) {
        if (gen[i] > max) {
            max = gen[i];
            index = i;
        }
    }
    cout << max << " " << index;

    return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/82502606