uva#524Prime Ring

素数环
A ring is composed of n (even number) circles as shown in diagram.
Put natural numbers 1, 2, . . . , n into each circle separately, and the
sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n ≤ 16)
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the
ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above
requirements.
You are to write a program that completes above process.
Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

#include<iostream>
#include<cstring>
using namespace std;
int vis[16],isprim[32],a[16];
int n;
void get_pr(){//埃氏筛
	int i,j;
	isprim[1] = 1;
	for(i = 2;i <= 32; ++i){
		if(!isprim[i]){
			for(j = i * i;j <= 32; j += i)
				isprim[j] = 1;
		}
	}
}
void ring(int cur){
	int i,j;
	if((cur == n) && (!isprim[a[0] + a[n - 1]])){
		for(i = 0;i < n; ++i){
			printf("%d",a[i]);
			if(i < n - 1)
				printf(" ");
		}
		printf("\n");
	}
	else{
		for(i = 2;i <= n; ++i){//1恒为首个元素
			if(!vis[i] && !isprim[a[cur - 1] + i]){
				a[cur] = i;
				vis[i] = 1;
				ring(cur + 1);
				vis[i] = 0;
			}
		}
	}
}
int main(){
//	freopen("d://poj//data.txt","w",stdout);
	int i = 1;
	get_pr();
	a[0] = 1;
	while(scanf("%d",&n) != EOF){
		if(i > 1)
			printf("\n");
		printf("Case %d:\n",i++);
		memset(vis,0,sizeof(vis));
		ring(1);
	}
	return 0;
}

本来就是练习练习回溯法。
uva就是shift,最后一组数据没有换行,好像很严格的样子。

发布了53 篇原创文章 · 获赞 0 · 访问量 722

猜你喜欢

转载自blog.csdn.net/weixin_38894974/article/details/104518095
今日推荐