hdu 2648 Shopping (application of map)

Portal

topic:

Problem Description

Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called “memory”. Now she wants to know the rank of this shop’s price after the change of everyday.

Input

One line contians a number n ( n<=10000),stands for the number of shops.
Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.
Then a line contians a number m (1<=m<=50),stands for the days .
Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s.

Output

Contains m lines ,In the ith line print a number of the shop “memory” ‘s rank after the ith day. We define the rank as :If there are t shops’ price is higher than the “memory” , than its rank is t+1.

Sample Input

3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory

Sample Output

1
2

Code:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    
    
	int n;
	map<string,int> mp;
	map<string,int>::iterator it;
	while(cin>>n)
	{
    
    
		string s;
		int p;
		for(int i=1;i<=n;i++) cin>>s;
		int m;
		cin>>m;
		while(m--)
		{
    
    
			for(int i=1;i<=n;i++){
    
    
				cin>>p>>s;
				mp[s]+=p;
			}
			int ans=1;
			for(it=mp.begin();it!=mp.end();it++){
    
    
				if(it->second>mp["memory"]){
    
    
					ans++;
				}
			}
			cout<<ans<<endl;
		}
		mp.clear();
	}
	return 0;
}
/*
3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory
*/

to sum up:

The high efficiency of map comes from the fact that it uses a balanced binary tree for storage and access, which can complete the mapping of different types to different types

Guess you like

Origin blog.csdn.net/Lzhzl211/article/details/114842122