A+B series of questions five

Topic description

Your task is to calculate the sum of some integers. 

enter

Input contains an integer N in the first line, and then N lines follow. 
Each line starts with a integer M, and then M integers follow in the same line. 

output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 

sample input

2
4 1 2 3 4
5 1 2 3 4 5

Sample output

10
15

Time Limit: 1 Sec Memory Limit: 128 MB

Code:

#include<stdio.h>

int main()
{
    int n = 0;
    int num = 0;
    int sum = 0;
    int temp = 0;
    while(scanf("%d", &num) != EOF)
    {
        while(num--)
        {
            scanf("%d", &n);
            sum = 0;
            while(n--)
            {
                scanf("%d", &temp);
                sum += temp;
            }
            printf("%d\n", sum);
        }
    }
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325646363&siteId=291194637