HDU - 3998 Sequence

There is a sequence X (i.e. x[1], x[2], ..., x[n]). We define increasing subsequence of X 

as x[i1], x[i2],...,x[ik], which satisfies follow conditions: 
1) x[i1] < x[i2],...,<x[ik]; 
2) 1<=i1 < i2,...,<ik<=n 

As an excellent program designer, you must know how to find the maximum length of the 
increasing sequense, which is defined as s. Now, the next question is how many increasing 
subsequence with s-length can you find out from the sequence X. 

For example, in one case, if s = 3, and you can find out 2 such subsequence A and B from X. 
1) A = a1, a2, a3. B = b1, b2, b3. 
2)  Each ai or bj(i,j = 1,2,3) can only be chose once at most. 

Now, the question is: 
1) Find the maximum length of increasing subsequence of X(i.e. s). 
2) Find the number of increasing subsequence with s-length under conditions described (i.e. num).

Input

The input file have many cases. Each case will give a integer number n.The next line will 

have n numbers.OutputThe output have two line. The first line is s and second line is num.Sample Input
4
3 6 2 5
Sample Output
2
2

 

answer:

    int sum = 1;

    Continue to seek LIS and delete each number. If the length of LIS remains unchanged, sum++, otherwise stop and output sum.

Code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAXN = 100005;

int book[MAXN]; /*Record the minimum number at the end of the subscript of the board*/
bool mark[MAXN];/*Mark the integer whether to delete*/
int board[MAXN];/*Store integer*/
int pre[MAXN];/*record the subscript of each integer preceding the integer in the board*/
int MaxLen; /*First LIS*/

int B_S(int a,int len){
	int left = 0;
	int right = len;
	while(left<right){
		int mid = left+(right-left)/2;
		if(board[book[mid]]>=a)right = mid;
		else left = mid+1;
	}
	return left;
}

int LIS(int length){
	int len ​​= 0;
	memset(book,-1,sizeof(book));
	memset(pre,-1,sizeof(pre));
	for(int i=0 ; i<length ; i++){
		if(mark[i]){
			int temp = B_S(board[i],len);
			if(book[temp] == -1)len++;
			book[temp] = i;
			if(temp)pre[i] = book[temp-1];
		}
	}
	int t = book[len-1];
	while(t != -1){
		mark[t] = false;
		t = pre[t];
	}
	return len;
}


int main(){
	
	int N;
	while(scanf("%d",&N)!=EOF){
		for(int i=0 ; i<N ; i++)scanf("%d",&board[i]);
		memset(mark,true,sizeof(mark));
		MaxLen = LIS(N);
		int T;
		int sum = 1;
		while(T = LIS(N)){
			if(T == MaxLen)sum++;
			else break;
		}
		printf("%d\n%d\n",MaxLen,sum);
	}
	
	return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=326061647&siteId=291194637