POJ - 2349&UVA - 10369 --Arctic Network (最小生成树)

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1
2 4
0 100
0 300
0 600
150 750
Sample Output
212.13

题意:哨所有两种通信方式,一种是通过卫星,范围是无限长的(但只有S条卫星通道)。另一种是无线电,距离为D(随着D的增大,成本也增加)。共有P个哨所,并给出其坐标。求出满足哨所相连,最小的距离D。

题解:既然有卫星距离无限长,距离长的哨所之间肯定首选卫星啦,将距离从大到小排序,合并S条线路后输出此时的距离,即第·S-1大的有效距离(因为可能有些距离是多余的,合并不了,这也是用并查集的一个原因)。

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int t,n,s;
int f[1020];
struct note
{
    int u,v;
    double l;
} q[300000];
struct work
{
    double x,y;
} p[1000];
void init()
{
    for(int i=0; i<=n; i++)
    {
        f[i]=i;
    }
}
int getf(int v)
{
    if(f[v]==v)return v;
    else
    {
        f[v]=getf(f[v]);
        return f[v];
    }
}
int merge(int v,int u)
{
    int t1=getf(v);
    int t2=getf(u);
    if(t1!=t2)
    {
        f[t2]=t1;
        return 1;
    }
    return 0;
}
int cmp(note a,note b)
{
    return a.l<b.l;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&s,&n);
        init();
        for(int i=1; i<=n; i++)
        {
            scanf("%lf%lf",&p[i].x,&p[i].y);
        }
        int cnt=0;
        for(int i=1; i<=n; i++)
            for(int j=i+1; j<=n; j++)
            {
                q[cnt].u=i,q[cnt].v=j;
                q[cnt++].l=sqrt((p[i].x-p[j].x)*(p[i].x-p[j].x)+(p[i].y-p[j].y)*(p[i].y-p[j].y));
            }
        int num=0;
        sort(q,q+cnt,cmp);
        for(int i=0; i<cnt; i++)
        {
            if(merge(q[i].u,q[i].v))
            {
                num++;
            }
            if(num==n-s)
            {
                printf("%.2f\n",q[i].l);
                break;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zitian246/article/details/80096087