Arctic Network( POJ - 2349)

题目:

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one
communication path (direct or indirect) between every pair of outposts.
Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

最小生成树prime模板题目,不过题目中给出有的距离可以用卫星通信,所以把每一个最短权值求出来,然后从大到小排序,取第m个权值为最大权值。

程序代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
struct node
{
	int x;
	int y;
}q[50000];
int e[2000][2000],dis[5000],book[5000];
double a[5000];
int main()
{
	int n,m,i,j,k,min,t1,t2,t3;
	int inf=99999999;
	int count,sum;
	int N;
	double tem;
	scanf("%d",&N);
	while(N--)
	{
		count=0;
		memset(dis,0,sizeof(dis));
		memset(book,0,sizeof(book));
		memset(a,0,sizeof(a));
		scanf("%d%d",&n,&m);
		for(i=1;i<=m;i++)
			scanf("%d%d",&q[i].x,&q[i].y);
		for(i=1;i<=m;i++)
			for(j=1;j<=m;j++)
				if(i==j)	e[i][j]=0;
				else		e[i][j]=inf;
		for(i=1;i<m;i++)
			for(j=i+1;j<=m;j++)
				e[i][j]=e[j][i]=(q[i].x-q[j].x)*(q[i].x-q[j].x)+(q[i].y-q[j].y)*(q[i].y-q[j].y);
		for(i=1;i<=m;i++)
			dis[i]=e[1][i];
		book[1]=1;
		count++;
		while(count<m)
		{
			min=inf;
			for(i=1;i<=m;i++)
			{
				if(book[i]==0&&dis[i]<min)
				{
					min=dis[i];
					j=i;
				}
			}
			book[j]=1;
			a[count]=sqrt(dis[j]);
			count++;
			for(k=1;k<=m;k++)
			{
				if(book[k]==0&&dis[k]>e[j][k])
					dis[k]=e[j][k];
			}
		}
		for(i=1;i<m;i++)//把权值从大到小排序
			for(j=i+1;j<m;j++)
			{
				if(a[i]<a[j])
				{
					tem=a[i];
					a[i]=a[j];
					a[j]=tem;
				}
			}
		printf("%.2f\n",a[n]);
	}
	return 0;	
} 
发布了67 篇原创文章 · 获赞 39 · 访问量 2739

猜你喜欢

转载自blog.csdn.net/qq_44859533/article/details/99670536
今日推荐