搜索二叉树建立

 
 

树结构练习——排序二叉树的中序遍历

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

在树结构中,有一种特殊的二叉树叫做排序二叉树,直观的理解就是——(1).每个节点中包含有一个关键值 (2).任意一个节点的左子树(如果存在的话)的关键值小于该节点的关键值 (3).任意一个节点的右子树(如果存在的话)的关键值大于该节点的关键值。现给定一组数据,请你对这组数据按给定顺序建立一棵排序二叉树,并输出其中序遍历的结果。
 

Input

输入包含多组数据,每组数据格式如下。
第一行包含一个整数n,为关键值的个数,关键值用整数表示。(n<=1000)
第二行包含n个整数,保证每个整数在int范围之内。

Output

为给定的数据建立排序二叉树,并输出其中序遍历结果,每个输出占一行。
 

Sample Input

1
2
2
1 20

Sample Output

2
1 20
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct node
{
    int  data;
    struct node *lt, *rt;
};

struct node *Insert(struct node *root, int x)
{
    if(!root)
    {
        struct node *root;
        root = (struct node *)malloc(sizeof(struct node));
        root->data = x;
        root->lt = root->rt = NULL;
        return root;
    }
    else
    {
        if(x<root->data)
            root->lt = Insert(root->lt, x);
        else
            root->rt = Insert(root->rt, x);
    }

     return root;
}

///中序遍历
void mid(struct node *root)
{
    if(root)
    {
        mid(root->lt);
        printf("%d ", root->data);
        mid(root->rt);
    }
}
int main()
{
    int n;
    while(scanf("%d", &n)!=EOF)
    {
        struct node *root = NULL;
        int x;
        while(n--)
        {
            scanf("%d", &x);
            root = Insert(root, x);
        }
        mid(root);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/aqa2037299560/article/details/79432380