对于大数__int128的使用

对于大数__int128的使用

__int64是可以直接使用的,相当于 long long int。但是呢这个不是最大的。最大的可以调用__int128。
唯独区别的就是赋值和输出需要用函数来实现。
首先看看怎么用。

例如:
计算 a+b的值

int main() {
__int128 a = read();
__int128 b = read();
write(a + b);
return 0;
}

OK咱们现在实现read()和write()

read()

inline __int128 read() {
	__int128 x=0,f=1;
	char ch=getchar();
	while(ch<'0'||ch>'9') {
		if(ch=='-')f=-1;
		ch=getchar();
	}
	while(ch>='0'&&ch<='9') {
		x=x*10+ch-'0';
		ch=getchar();
	}
	return x*f;
}

write()

inline void write(__int128 x) {
	if(x<0) {
		putchar('-');
		x=-x;
	}
	if(x>9)write(x/10);
	putchar(x%10+'0');
}

举个栗子
a+b+c+d=?
问题描述

This is a very simple problem! Your only job is to calculate a + b + c + d

输入

There are several cases.In the first line, there is a single integer T.(T <= 200)In the next T lines, each line contains four integers a, b, c and d。(-2^63 <= a,b,c,d <=2^63)

Sample Input

1
1 2 3 4

Sample Output

10

很明显数据太大
4倍根本写不过来,所以用__int128是是个好想法

代码如下

#include <bits/stdc++.h>
using namespace std;
inline __int128 read() {
	__int128 x=0,f=1;
	char ch=getchar();
	while(ch<'0'||ch>'9') {
		if(ch=='-')f=-1;
		ch=getchar();
	}
	while(ch>='0'&&ch<='9') {
		x=x*10+ch-'0';
		ch=getchar();
	}
	return x*f;
}
inline void write(__int128 x) {
	if(x<0) {
		putchar('-');
		x=-x;
	}
	if(x>9)write(x/10);
	putchar(x%10+'0');
}
int main() {
	int n;
	cin>>n;
	while(n--) {
		__int128 a=read();
		__int128 b=read();
		__int128 c=read();
		__int128 d=read();
		write(a+b+c+d);
		putchar('\n');
	}
	return 0;
}

by-轮月

发布了32 篇原创文章 · 获赞 12 · 访问量 1194

猜你喜欢

转载自blog.csdn.net/qq_35339563/article/details/103940172
128