欧拉公式-素数

Euler is a well-known matematician, and, among many other things, he discovered that the formula n 2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41. Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s known that for n ≤ 10000000, there are 47,5% of primes produced by the formula!

So, you’ll write a program that will output how many primes does the formula output for a certain interval.

Input

Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must read until the end of the file.

Output

For each pair a, b read, you must output the percentage of prime numbers produced by the formula in this interval (a ≤ n ≤ b) rounded to two decimal digits.

Sample Input

0 39

0 40

39 40

Sample Output

100.00

97.56

50.00

题意就是把两数之间的数代入此公式,把是素数的统计起来,算出百分比

如果直接暴力写会超时,因此要用到打表。先把表打出来,用的时候直接拿就行了

代码如下

#include<stdio.h>
#include<math.h>
#include<string.h>
int book[10005];
void ti()
{
    int i,j,m;
    memset(book,0,sizeof(book));
    for(i=0;i<=10005;i++)
    {
        int f=0;
        m=i*i+i+41;
        for(j=2;j<=sqrt(m);j++)
        {
            if(m%j==0)
            {
                f=1;
                break;
            }
        }
        if(f==0)
            book[i]=1;
    }
    for(i=0;i<=10000;i++)
        book[i]=book[i]+book[i-1];
}
int main()
{
    int a,b,f;
    ti();
    while(~scanf("%d%d",&a,&b))
    {
        double c=book[b]-book[a-1];
        printf("%.2lf\n",c/(b-a+1)*100.0+1e-8);
    }
    return 0;
}
发布了30 篇原创文章 · 获赞 1 · 访问量 229

猜你喜欢

转载自blog.csdn.net/weixin_46204099/article/details/105279075
今日推荐