UVA - 558 Wormholes(SPFA判负环)

In the year 2163, wormholes were discovered. A wormhole is a subspace tunnel through space and time
connecting two star systems. Wormholes have a few peculiar properties:
• Wormholes are one-way only.
• The time it takes to travel through a wormhole is negligible.
• A wormhole has two end points, each situated in a star system.
• A star system may have more than one wormhole end point within its boundaries.
• For some unknown reason, starting from our solar system, it is always possible to end up in any
star system by following a sequence of wormholes (maybe Earth is the centre of the universe).
• Between any pair of star systems, there is at most one wormhole in either direction.
• There are no wormholes with both end points in the same star system.
All wormholes have a constant time difference between their end points. For example, a specific
wormhole may cause the person travelling through it to end up 15 years in the future. Another wormhole
may cause the person to end up 42 years in the past.
A brilliant physicist, living on earth, wants to use wormholes to study the Big Bang. Since warp
drive has not been invented yet, it is not possible for her to travel from one star system to another one
directly. This can be done using wormholes, of course.
The scientist wants to reach a cycle of wormholes somewhere in the universe that causes her to end
up in the past. By travelling along this cycle a lot of times, the scientist is able to go back as far in
time as necessary to reach the beginning of the universe and see the Big Bang with her own eyes. Write
a program to find out whether such a cycle exists.
Input
The input file starts with a line containing the number of cases c to be analysed. Each case starts with
a line with two numbers n and m. These indicate the number of star systems (1 ≤ n ≤ 1000) and
the number of wormholes (0 ≤ m ≤ 2000). The star systems are numbered from 0 (our solar system)
through n − 1 . For each wormhole a line containing three integer numbers x, y and t is given. These
numbers indicate that this wormhole allows someone to travel from the star system numbered x to the
star system numbered y, thereby ending up t (−1000 ≤ t ≤ 1000) years in the future.
Output
The output consists of c lines, one line for each case, containing the word ‘possible’ if it is indeed
possible to go back in time indefinitely, or ‘not possible’ if this is not possible with the given set of
star systems and wormholes.
Sample Input
2
3 3
0 1 1000
1 2 15
2 1 -42
4 4
0 1 10
1 2 20
2 3 30
3 0 -60
Sample Output
possible
not possible

SPFA判法

#include <bits/stdc++.h>
using namespace std;
const int N = 1e7 + 5;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x3f3f3f3f;
int n, m;                         // 总点数
int h[N], w[N], e[N], ne[N], idx; // 邻接表存储所有边
int dist[N],cnt[N];              // dist[x]存储1号点到x的最短距离,cnt[x]存储1到x的最短路中经过的点数
bool st[N];                       // 存储每个点是否在队列中
void add(int a, int b, int c)
{
    e[idx] = b, ne[idx] = h[a], w[idx] = c, h[a] = idx++;
}
// 如果存在负环,则返回true,否则返回false。
bool spfa()
{
   memset(cnt,0,sizeof cnt);
   memset(st,0,sizeof st);
   memset(dist,0,sizeof dist);
    queue<int> q;
    for (int i = 0; i < n; i++)
    {
        q.push(i);
        st[i] = true;
    }

    while (q.size())
    {
        auto t = q.front();
        q.pop();
        st[t] = false;
        for (int i = h[t]; i != -1; i = ne[i])
        {
            int j = e[i];
            if (dist[j] > dist[t] + w[i])
            {
                dist[j] = dist[t] + w[i];
                cnt[j] = cnt[t] + 1;
                if (cnt[j] >= n)
                    return true; // 如果从1号点到x的最短路中包含至少n个点(不包括自己),则说明存在环
                if (!st[j])
                {
                    q.push(j);
                    st[j] = true;
                }
            }
        }
    }

    return false;
}

int main()
{

    int t;
    scanf("%d", &t);
    int u, v, w;
    while (t--)
    {
    	idx=0;
        memset(h,-1,sizeof h);
        scanf("%d%d", &n, &m);
        for (int i = 0; i < m; i++)
        {
            scanf("%d%d%d", &u, &v, &w);
            add(u, v, w);
           
        }
        
        bool flag=spfa();
        if (!flag)
        {
            printf("not possible\n");
        }
        else
        {
            printf("possible\n");
            
        }
    }
    return 0;
}

bellman-ford判法

#include <cstdio>
#define MAX 10000

using namespace std;

struct WORMHOLE{
    int x,y,t;
};

bool BellmanFord(int vertex_num, int edge_num){
    // 初始化
    int dist[vertex_num];
    struct WORMHOLE wormhole[edge_num];
    for(int i=0; i<edge_num; i++){
        scanf("%d %d %d", &wormhole[i].x, &wormhole[i].y,&wormhole[i].t);
    }
    dist[0] = 0;
    for (int i=1; i < vertex_num; i++)
        dist[i] = MAX;

    // n次循环求负闭环
    for(int i=1; i<vertex_num; ++i){
		for(int j=0; j<edge_num; ++j){
			if(dist[wormhole[j].y] > dist[wormhole[j].x] + wormhole[j].t){
                dist[wormhole[j].y] = dist[wormhole[j].x] + wormhole[j].t;
			}
		}
	}
	int f=0;
	for(int j=0; j<edge_num; ++j){
		if(dist[wormhole[j].y] > dist[wormhole[j].x] + wormhole[j].t){
			f=1;
			break;
		}
	}
	return f;
}

int main()
{
    int c;
    int n, m;
    scanf("%d", &c);
    while(c--){
        //输入数据
        scanf("%d %d", &n, &m);
        printf("%s\n", BellmanFord(n, m)? "possible" : "not possible");
    }
    return 0;
}
发布了84 篇原创文章 · 获赞 12 · 访问量 2926

猜你喜欢

转载自blog.csdn.net/qq_43294914/article/details/103220308
今日推荐