POJ 2192 Zipper动态规划练习

Zipper
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18986   Accepted: 6790

Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order. 

For example, consider forming "tcraete" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: tcraete 

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: catrtee 

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree". 

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. 

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive. 

Output

For each data set, print: 

Data set n: yes 

if the third string can be formed from the first two, or 

Data set n: no 

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example. 

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

建立状态方程,opt[i][j] 表示 字符串1的前i个字符 和 字符串2 的前j个字符,可以匹配 字符串3 的最大个数。(即字符串2的前i个字符和字符串1的前j个字符在字符串3中出现的次数)

边界条件为opt[0][0]=0,if(str1[i-1]=str3[i-1]), opt[i][0]=opt[i-1][0]+1,if(str2[i-1]=str3[i-1]), opt[0][i]=opt[0][i-1]+1,

若否的话opt[i][0]=opt[i-1][0],opt[0][i]=opt[0][i-1]

一般的状态方程是

opt[i][j] = max(opt[i-1][j] + (str1[ i-1 ] == str3[ opt[i-1][j] ]), opt[i][j-1] + (str2[ j-1 ] == str3[ opt[i][j-1] ]) );

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

int max(int a,int b){
	return a > b ? a:b;
}

int main(){
	//freopen("in.txt","r",stdin);
	int t;
	scanf("%d",&t);
	char str1[210],str2[210],str3[410];
	int opt[410][410];
	for(int c=1; c<=t; c++){
		printf("Data set %d: ",c);
		scanf("%s %s %s", str1,str2,str3);
		int len1 = strlen(str1);
		int len2 = strlen(str2);
		int k = 0;
			opt[0][0] = 0;
	
		for(int i=1; i<=len2; i++){
			if(str2[i-1] == str3[i-1])
				opt[0][i] = 	opt[0][i-1] + 1;
			else
				opt[0][i] = opt[0][i-1];
		}
		for(int i=1; i<=len1; i++){
			if(str1[i-1] == str3[i-1])
				opt[i][0] = opt[i-1][0] + 1;
			else
				opt[i][0] =  opt[i-1][0];
		}
		
		for(int i=1; i<=len1; i++){
			for(int j=1; j<=len2; j++){
				
				opt[i][j] = max(opt[i-1][j] + (str1[ i-1 ] == str3[ opt[i-1][j] ]), opt[i][j-1] + (str2[ j-1 ] == str3[ opt[i][j-1] ]) );
				//cout << opt[i][j] << " ";
			}
		}
		if(opt[len1][len2] == len1 + len2){
			printf("yes\n");
		}else
			printf("no\n");
	
	}
	return 0;
}





猜你喜欢

转载自blog.csdn.net/wwxy1995/article/details/80189135
今日推荐