Zipper OpenJ_Bailian - 2192 (记忆化搜索)

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order. 

For example, consider forming "tcraete" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: tcraete 

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: catrtee 

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree". 

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. 

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive. 

Output

For each data set, print: 

Data set n: yes 

if the third string can be formed from the first two, or 

Data set n: no 

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example. 

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no
#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>

using namespace std;
char s1[250], s2[250], s3[500];
int dp[500][500];
int len1, len2, len3;

int dfs(int i, int j) {
	if (i == len1 && j == len2)
	return 1;
	if (dp[i][j] != -1) return dp[i][j];
	if (i < len1 && s1[i] == s3[i+j]) {
		if (dfs(i+1, j)) {
			return dp[i][j] = 1;
		}
	}
	if (j < len2 && s2[j] == s3[i+j]) {
		if (dfs(i, j+1)) {
			return dp[i][j] = 1;
		}
	}
	return dp[i][j] = 0;
}

int main(void) {
	int t, i = 1;
	scanf("%d", &t);
	while(t--) {

		scanf("%s %s %s", s1, s2, s3);
		len1 = strlen(s1);
		len2 = strlen(s2);
		len3 = strlen(s3);
		memset(dp, -1, sizeof(dp));
		printf("Data set %d: ", i);
		if(dfs(0,0)) {
			puts("yes");
		} else {
			puts("no");
		}
		++i;
		
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/nucleare/article/details/81191628