Packet Tracer (第三期)-7EIGRP高级配置与调试(待)

EIGRP高级配置与调试–PKA下载地址

拓扑图

在这里插入图片描述

地址分配表

在这里插入图片描述
场景

在本练习中,您的任务是在两个不同网络上实施 IPv4 和 IPv6 的 EIGRP。您的任务包括启用 EIGRP、分配路由器 ID、更改 hello 计时器、配置 EIGRP 总结路由和限制 EIGRP 通告。

要求

IPv4 的 EIGRP

  • · 使用自治系统 1 在启用 IPv4 的路由器上实施 EIGRP。
Route eigrp 1

-为环回接口使用有类网络地址。

Network 172.31.0.0

-使用通配符掩码来传播 R1、R2 和 IPv4-Edge 之间的 /30 网络。

Network 172.31.6.0 0.0.0.3

-使用默认方法来仅允许活动 EIGRP 串行接口发出的 EIGRP 更新。

Passive-interface default  //设置所有被动接口
No passive-interface s0/0/0  //将直连的接口取消被动接口

-不应总结通告。

No auto-summary
  • · 在 IPv4-Edge 上配置直连默认路由并在 EIGRP 更新中传播它。
Ip route 0.0.0.0 0.0.0.0 s0/1/0
Router ei 1
Redistribute static
  • · 配置 R1、R2 和 IPv4-Edge 之间的串行接口,使其每 10 秒发送一个 hello。
int s0/0/0
ip hello eigrp 1 10
  • · 在 R1 和 R2 上,配置环回网络的 EIGRP 总结路由。

在这里插入图片描述

扫描二维码关注公众号,回复: 11385582 查看本文章

这里以R1为例
172.31.0000 0000.0
172.31.0000 0000.128
172.31.0000 0001.0
172.31.0000 0001.128
从左到右第一个不相同的是第三段的最后一个,那就以此往后为主机位,主机位全为0,前部分不变;
那么该总结路由为172.31.0.0/23 ;注意子网掩码此时为23位

Int  s0/0/0
Ip summary-address eigrp 1 172.31.0.0  255.255.254.0
  • · R1 和 R2 在路由表中应该只有四条 EIGRP 路由,其中一条是默认路由 (D*EX)。IPv4-Edge在路由表中应该只有两条 EIGRP 路由。
Sh ip ro ei  //只有四条 EIGRP 路由
  • · 检验 R1 和 R2 是否能够对 IPv4 服务器执行 ping 操作。IPv4 服务器还应该能够对 R1 和 R2
    上每个环回地址执行 ping 操作。

IPv6 的 EIGRP

  • · 使用自治系统 1 在启用 IPv6 的路由器上实施 EIGRP。
Ipv6 unicast-routing  //打开IPV6协议

-为 IPv6-Edge 分配路由器 ID 1.1.1.1

ipv6 router eigrp 1
eigrp router-id 1.1.1.1

-为 R3 分配路由器 ID 3.3.3.3
-为 R4 分配路由器 ID 4.4.4.4

  • · 在 IPv6-Edge 上配置直连默认路由并在 EIGRP 更新中传播它。
Int s0/0/0
Ipv6 eigrp 1  //将个接口
Ipv6 route  ::/0 s0/1/0
  • · 在 R3 和 R4 上,配置环回网络的 EIGRP 总结路由。

在这里插入图片描述

  • · R3 和 R4 在路由表中应该只有四条 EIGRP 路由,包括默认外部路由。IPv6-Edge 在路由表中应该只有两条EIGRP 路由。

  • · 检验 R3 和 R4 是否能够对 IPv6 服务器执行 ping 操作。IPv6 服务器还应该能够对 R3 和 R4上每个环回地址执行 ping 操作。

ipv4路由器配置

R1配置

R1(config)#route eigrp 1
R1(config-router)#network 172.31.0.0
R1(config-router)#net 172.31.6.0 0.0.0.3
R1(config-router)#net 172.31.6.1 0.0.0.3
R1(config-router)#passive-interface default
R1(config-router)#no passive-interface s0/0/0
R1(config-router)#no auto-summary
R1(config-router)#int s0/0/0
R1(config-if)#ip hello-interval eigrp 1 10
R1(config-if)#in s0/0/0
R1(config-if)#ip summary-address eigrp 1 172.31.0.0 255.255.254.0

R2配置

R2(config)#route eigrp 1
R2(config-router)#network 10.10.0.0
R2(config-router)#net 10.10.8.0 0.0.0.3
R2(config-router)#passive-interface default
R2(config-router)#no passive-interface s0/0/1
R2(config-router)#no auto-summary
R2(config-router)#int s0/0/1
R2(config-if)#ip hello-interval eigrp 1 10
R2(config-if)#ip summary-add eigrp 1 10.10.0.0 255.255.248.0

IPv4-Edge配置

IPv4-Edge(config)#route eigrp 1

IPv4-Edge(config-router)#net 192.165.200.224 0.0.0.1
IPv4-Edge(config-router)#passive-interface default
IPv4-Edge(config-router)#no passive-interface s0/0/0
IPv4-Edge(config-router)#no passive-interface s0/0/1
IPv4-Edge(config-router)#no auto-summary
IPv4-Edge(config-router)#ip route 0.0.0.0 0.0.0.0 s0/1/0
%Default route without gateway, if not a point-to-point interface, may impact performance
IPv4-Edge(config)#route eigrp 1
IPv4-Edge(config-router)#redistribute static
IPv4-Edge(config-router)#int s0/0/0
IPv4-Edge(config-if)#ip hello-interval eigrp 1 10
IPv4-Edge(config-if)#int s0/0/1
IPv4-Edge(config-if)#ip hello-interval eigrp 1 10

ipv6路由器配置

R3配置

R3(config)#ipv6 unicast-routing
R3(config)#ipv6 router eigrp 1
R3(config-rtr)#eigrp router-id 3.3.3.3
R3(config-rtr)#no sh
R3(config-rtr)#int s0/0/0
R3(config-if)#ipv6 eigrp 1
R3(config-if)#int s0/0/0
R3(config-if)#ipv6 summary-address eigrp 1 2001:DB8:1:1:A000::/70

R4配置

R4(config)#ipv6 unicast-routing
R4(config)#ipv6 router eigrp 1
R4(config-rtr)#eigrp router-id 4.4.4.4
R4(config-rtr)#no sh
R4(config-rtr)#int s0/0/1
R4(config-if)#ipv6 eigrp 1
R4(config-if)#int s0/0/1
R4(config-if)#ipv6 summary-add eigrp 1 2001:DB8:1:1:BB00::/72

IPv6-Edge配置

IPv6-Edge>enable
IPv6-Edge#conf t
Enter configuration commands, one per line. End with CNTL/Z.
IPv6-Edge(config)#ipv6 unicast-routing
IPv6-Edge(config)#ipv6 router eigrp 1
IPv6-Edge(config-rtr)#eigrp router-id 1.1.1.1
IPv6-Edge(config-rtr)#no sh
IPv6-Edge(config-rtr)#int s0/0/0
IPv6-Edge(config-if)#ipv6 eigrp 1
IPv6-Edge(config-rtr)#int s0/0/1
IPv6-Edge(config-if)#ipv6 eigrp 1
IPv6-Edge(config-if)#ipv6 route ::/0 s0/1/0
IPv6-Edge(config)#route ei 1
IPv6-Edge(config-router)#redistribute static

猜你喜欢

转载自blog.csdn.net/qq_42530422/article/details/105554621