HDU 4737 A Bit Fun (位或运算)

A Bit Fun

Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 199 Accepted Submission(s): 123


Problem Description
There are n numbers in a array, as a 0, a 1 ... , a n-1, and another number m. We define a function f(i, j) = a i|a i+1|a i+2| ... | a j . Where "|" is the bit-OR operation. (i <= j)
The problem is really simple: please count the number of different pairs of (i, j) where f(i, j) < m.

Input
The first line has a number T (T <= 50) , indicating the number of test cases.
For each test case, first line contains two numbers n and m.(1 <= n <= 100000, 1 <= m <= 2 30) Then n numbers come in the second line which is the array a, where 1 <= a i <= 2 30.

Output
For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1.
Then follows the answer.

Sample Input
 
  
2 3 6 1 3 5 2 4 5 4

Sample Output
 
  
Case #1: 4 Case #2: 0

Source


 

import java.io.*;
import java.util.*;

public class Main {
	BufferedReader bu = new BufferedReader(new InputStreamReader(System.in));;
	PrintWriter pw = new PrintWriter(new OutputStreamWriter(System.out), true);
	StringTokenizer st;
	int t, n;
	long m;
	long[] a;
	public static void main(String[] args) throws Exception {
		new Main().work();
	}
	void work() throws Exception {
		t = nextInt();
		for (int p = 1; p <= t; p++) {
			pw.print("Case #" + p + ": ");
			n = next().intValue();
			m = next();
			a = new long[n + 1];

			for (int i = 1; i <= n; i++) {
				a[i] = next();
			}
			
			long count = 0,x;
			
			for (int i = 1; i <=n; i++) {
				long kp=a[i]|a[i];
				if(kp>=m)
					continue;
				else{
					x=a[i];
					count++;
				}
				for (int j = i+1; j <= n; j++) {
					if(a[j]>=m)
						break;
					x = x | a[j];
					if (x>=m)
						 break;
						count++;
				}
			}
			pw.println(count);
		}
	}

	public int nextInt() throws Exception {
		return Integer.parseInt(bu.readLine());
	}

	public Long next() throws Exception {
		while (st == null || !st.hasMoreTokens())
			st = new StringTokenizer(bu.readLine());
		return Long.parseLong(st.nextToken());
	}
}


 

猜你喜欢

转载自blog.csdn.net/long71751380/article/details/11693387