【HDU 4268】Alice and Bob 贪心 set

Problem Description
Alice and Bob’s game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob’s. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob’s cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.

Input
The first line of the input is a number T (T <= 40) which means the number of test cases.
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice’s card, then the following N lines means that of Bob’s.

Output
For each test case, output an answer using one line which contains just one number.

Sample Input
2
2
1 2
3 4
2 3
4 5
3
2 3
5 7
6 8
4 1
2 5
3 4

Sample Output
1
2

题意:A B各有n张不同长宽的牌,问A最多能覆盖多少张B的牌(长宽严格大于对方)

思路:

很经典的贪心问题。(这里把长宽用L,R代替)
首先考虑贪心策略:A当前这张牌的最优解肯定是在B的牌中,所有L小于A这张的L集合里,R和这张牌的R最接近的。因为这样就可以充分利用这张牌的长宽。不然有可能有这张牌挑个小一点R覆盖,但是后面的牌不够那么长的R接着覆盖了。
那怎么实现呢?主要的思路就是对各自进行L升序排序,然后A拿一张牌,就把小于等于它的L且还没在集合里的B牌压进集合里面,然后在集合里面二分查找最接近A的R的对应B的R。这里可以借助set容器实现。

AC代码:

#include<iostream>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include <queue>
#include<sstream>
#include <stack>
#include <set>
#include <bitset>
#include<vector>
#define FAST ios::sync_with_stdio(false)
#define abs(a) ((a)>=0?(a):-(a))
#define sz(x) ((int)(x).size())
#define all(x) (x).begin(),(x).end()
#define mem(a,b) memset(a,b,sizeof(a))
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
#define rep(i,a,n) for(int i=a;i<=n;++i)
#define per(i,n,a) for(int i=n;i>=a;--i)
#define pb push_back
#define mp make_pair
#define fi first
#define se second
using namespace std;
typedef long long ll;
typedef pair<ll,ll> PII;
const int maxn = 1e5+200;
const int inf=0x3f3f3f3f;
const double eps = 1e-7;
const double pi=acos(-1.0);
const int mod = 1e9+7;
inline int lowbit(int x){return x&(-x);}
ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
void ex_gcd(ll a,ll b,ll &d,ll &x,ll &y){if(!b){d=a,x=1,y=0;}else{ex_gcd(b,a%b,d,y,x);y-=x*(a/b);}}//x=(x%(b/d)+(b/d))%(b/d);
inline ll qpow(ll a,ll b,ll MOD=mod){ll res=1;a%=MOD;while(b>0){if(b&1)res=res*a%MOD;a=a*a%MOD;b>>=1;}return res;}
inline ll inv(ll x,ll p){return qpow(x,p-2,p);}
inline ll Jos(ll n,ll k,ll s=1){ll res=0;rep(i,1,n+1) res=(res+k)%i;return (res+s)%n;}
inline ll read(){ ll f = 1; ll x = 0;char ch = getchar();while(ch>'9'|ch<'0') {if(ch=='-') f=-1; ch = getchar();}while(ch>='0'&&ch<='9') x = (x<<3) + (x<<1) + ch - '0',  ch = getchar();return x*f; }
int dir[4][2] = { {1,0}, {-1,0},{0,1},{0,-1} };

typedef struct Pos
{
    ll l;
    ll r;
} P;

P a[maxn];
P b[maxn];
ll vis[maxn];

bool cmp(P a, P b)
{
    return a.l < b.l;
}

set<ll> res;

int main()
{
    int kase;
    cin>>kase;
    while(kase--)
    {
        ll n = read(); mem(vis,0); res.clear();
        rep(i,1,n) a[i].l = read(), a[i].r = read();
        rep(i,1,n) b[i].l = read(), b[i].r = read();
        sort(a+1,a+1+n,cmp); sort(b+1,b+1+n,cmp);
        ll sum = 0;
        ll pos = 1;
        rep(i,1,n)
        {
             while(pos<=n&&a[i].l >= b[pos].l) res.insert(b[pos].r) , pos++;
             auto it = res.upper_bound(a[i].r);
             if(res.size()&&it!=res.begin()) it--;
             if(res.size()&&(*it)<=a[i].r ) sum++, res.erase(it);
        }
        cout<<sum<<'\n';
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_45492531/article/details/107559756