【MST最小生成树】Freckles

Freckles
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8979   Accepted: 4262

Description

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 
Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

Input

The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41

Source

Waterloo local 2000.09.23



#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
#define NMAX 101
int n;
int Tree[NMAX];
int findRoot(int x){
	if(Tree[x]==-1)
		return x;
	int tmp=findRoot(Tree[x]);
	Tree[x]=tmp;
	return tmp;
}
struct Edge{
	int a,b;
	double cost;
	bool operator<(const Edge& e) const{
		return cost<e.cost;
	}
}edges[6000];
struct Point{
	double x,y;
	double getInstance(Point A){
		double tmp=(x-A.x)*(x-A.x)+(y-A.y)*(y-A.y);
		return sqrt(tmp);
	}
}list[NMAX];
int main(){
	while(scanf("%d",&n)!=EOF){
		//memset(Tree,-1,sizeof(Tree));
		for(int i=1;i<=n;i++){
			scanf("%lf%lf",&list[i].x,&list[i].y);
		}
		int size=0;
		for(int i=1;i<=n;i++){
			for(int j=i+1;j<=n;j++){
				edges[size].a=i;
				edges[size].b=j;
				edges[size].cost=list[i].getInstance(list[j]);
				size++;
			}
		}
		sort(edges,edges+size);
		for(int i=1;i<=n;i++){
			Tree[i]=-1;
		}
		double ans=0;
		for(int i=0;i<size;i++){
			int fa=findRoot(edges[i].a);
			int fb=findRoot(edges[i].b);
			if(fa!=fb){
				Tree[fa]=fb;
				ans+=edges[i].cost;
			}
		}
		printf("%.2lf\n",ans);

	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_33837704/article/details/80504144