TOJ 2371 Freckles 最小生成树 prim

2371: Freckles

描述

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 
Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

输入

The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

输出

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

样例输入

3
1.0 1.0
2.0 2.0
2.0 4.0

样例输出

3.41

扫描二维码关注公众号,回复: 2503389 查看本文章

prim模板题。给n个点,问最短多少距离可以把他们都连起来。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long
int n;
double graph[101][101];
int vis[101];
double prim()
{
	memset(vis,0,sizeof vis);
	double ans=0,low[1005];
	int pos=0;
	vis[0]=1;
	for(int i=0;i<n;i++)
	low[i]=graph[pos][i];
	for(int i=1;i<n;i++)
	{
		double min=inf;
		for(int j=0;j<n;j++)
		{
			if(!vis[j]&&min>low[j])
			{
				min=low[j];
				pos=j;
			}
		}
		vis[pos]=1;
		ans+=min;
		for(int k=1;k<=n;k++)
		{
			if(!vis[k]&&low[k]>graph[pos][k])
			low[k]=graph[pos][k];
		}
	}
	return ans;
}
int main()
{
	int i,j;
	double x[105],y[105];
	scanf("%d", &n);
	memset(graph,0,sizeof graph);
	for(i=0;i<n;i++)
	scanf("%lf%lf",&x[i],&y[i]);
	for(i=0;i<n;i++) 
	{
		for(j=i+1;j<n;j++) 
		graph[i][j]=graph[j][i]=sqrt((x[i]- x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i] - y[j]));
	}
	printf("%.2lf\n",prim());
}

猜你喜欢

转载自blog.csdn.net/thewise_lzy/article/details/81210275